summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-18 08:17:58 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-18 08:17:58 +0200
commit1542220a4deb84dd46206b1a94a8e71a31e386ed (patch)
treece90b10b2795e86fcfdbe55e08fa57ab96ef18d1 /xfce-base
parentdev-python/bitstring: Bump to 3.1.8 (diff)
downloadgentoo-1542220a4deb84dd46206b1a94a8e71a31e386ed.tar.gz
gentoo-1542220a4deb84dd46206b1a94a8e71a31e386ed.tar.bz2
gentoo-1542220a4deb84dd46206b1a94a8e71a31e386ed.zip
xfce-base/thunar: Bump to 4.17.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/thunar/Manifest1
-rw-r--r--xfce-base/thunar/thunar-4.17.4.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/xfce-base/thunar/Manifest b/xfce-base/thunar/Manifest
index 1c25b45799c2..b985c4c15539 100644
--- a/xfce-base/thunar/Manifest
+++ b/xfce-base/thunar/Manifest
@@ -1,2 +1,3 @@
DIST thunar-4.16.8.tar.bz2 2429407 BLAKE2B 0af1c14fff30f276c279ff459e33ff4c23533e1ce494cadba02fca6436c1d1d2a0c8ea302dfb9c7b5ff9b6d7a69a80996afa1274cc9f3c66f112b8230d8b30f3 SHA512 722caeef9a8a074bac705b0108faab418009e61d8e177838b6a63cbf29f7b9c78e3a135b8a59f154e978feb811d5d115810df2b2e9d53d93f1c34e62a2d5f7b8
DIST thunar-4.17.3.tar.bz2 2427025 BLAKE2B 5fde8faf29f8b8f78a604c12cd0366187865d2c176109a8501500af573e77cfaf53aecc145674f2f49d730f2596c06e3304c4b2e033759430b1d3fd06439310b SHA512 7394121dd995296802b50ae6188a56228dec82f9cb1c29cf8c9bc4db6a69921e78f6a2bfcab459578faf64703eecc59a04ce6f4d623300e54faa2e0b4e261699
+DIST thunar-4.17.4.tar.bz2 2475127 BLAKE2B 1464162544f7d5f646975e9f663db1d4fb14249f87df013f68f04810eb2b961507a9b90b05cfe3dfbe9188c002ccc10143ee77b671e2b196b7ec3df803d05bf7 SHA512 0271d6925955692076168f4227c946479dc17cb8c0bf92d8dca523575f187c481b4c5f876ad13cdeadbdc67a4b773a1b88166a0eddc7b3ff4c8abb40135b84bf
diff --git a/xfce-base/thunar/thunar-4.17.4.ebuild b/xfce-base/thunar/thunar-4.17.4.ebuild
new file mode 100644
index 000000000000..63884c064f5a
--- /dev/null
+++ b/xfce-base/thunar/thunar-4.17.4.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit xdg-utils
+
+DESCRIPTION="File manager for the Xfce desktop environment"
+HOMEPAGE="https://www.xfce.org/projects/ https://docs.xfce.org/xfce/thunar/start"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="0/3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="exif introspection libnotify pcre +trash-panel-plugin udisks"
+
+GVFS_DEPEND=">=gnome-base/gvfs-1.18.3"
+DEPEND=">=dev-libs/glib-2.50
+ >=x11-libs/gdk-pixbuf-2.14
+ >=x11-libs/gtk+-3.22:3
+ >=xfce-base/exo-4.17.0:=
+ >=xfce-base/libxfce4ui-4.17.0:=
+ >=xfce-base/libxfce4util-4.17.0:=
+ >=xfce-base/xfconf-4.12:=
+ exif? ( >=media-libs/libexif-0.6.19:= )
+ introspection? ( dev-libs/gobject-introspection:= )
+ libnotify? ( >=x11-libs/libnotify-0.7 )
+ pcre? ( >=dev-libs/libpcre-6:= )
+ trash-panel-plugin? ( >=xfce-base/xfce4-panel-4.10:= )
+ udisks? ( dev-libs/libgudev:= )"
+RDEPEND="${DEPEND}
+ >=dev-util/desktop-file-utils-0.20-r1
+ x11-misc/shared-mime-info
+ trash-panel-plugin? ( ${GVFS_DEPEND} )
+ udisks? (
+ virtual/udev
+ ${GVFS_DEPEND}[udisks,udev]
+ )"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_configure() {
+ local myconf=(
+ $(use_enable introspection)
+ $(use_enable udisks gudev)
+ $(use_enable libnotify notifications)
+ $(use_enable exif)
+ $(use_enable pcre)
+ $(use_enable trash-panel-plugin tpa-plugin)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ elog "If you were using an older Xfce version and Thunar fails to start"
+ elog "with a message similar to:"
+ elog " Failed to register: Timeout was reached"
+ elog "you may need to reset your xfce4 session:"
+ elog " rm ~/.cache/sessions/xfce4-session-*"
+ elog "See https://bugs.gentoo.org/698914."
+
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}