summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-23 00:29:29 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-23 00:35:47 +0100
commit184a5dbd28efc93f81e3428640223a0cf80d1216 (patch)
tree49f3d1bdc9caf6456c2035cd96c546a8365b7879 /xfce-base
parentxfce-base/garcon: Bump to 0.8.0 (diff)
downloadgentoo-184a5dbd28efc93f81e3428640223a0cf80d1216.tar.gz
gentoo-184a5dbd28efc93f81e3428640223a0cf80d1216.tar.bz2
gentoo-184a5dbd28efc93f81e3428640223a0cf80d1216.zip
xfce-base/xfce4-settings: Bump to 4.16.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/xfce4-settings/Manifest1
-rw-r--r--xfce-base/xfce4-settings/xfce4-settings-4.16.0.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/xfce-base/xfce4-settings/Manifest b/xfce-base/xfce4-settings/Manifest
index 3505cea50eca..b4427e463fe5 100644
--- a/xfce-base/xfce4-settings/Manifest
+++ b/xfce-base/xfce4-settings/Manifest
@@ -1,2 +1,3 @@
DIST xfce4-settings-4.14.3.tar.bz2 1201308 BLAKE2B daf20e5adda24f3c1ecc88506c1a1cd03b33b379bafc236ed3b99404b816803288041de7d507072a311c3966bb0e040986e358ea94d01636c56ea31c1b843c8d SHA512 fcc5bfa98d8903dc3ac51ec909e542485a44f6c11ddca815508c2ed913410a0becd54b2db6761ee48f5a20d6ca08377eeefbb54bd0cb7cde0a0c0d4b65802ab5
DIST xfce4-settings-4.15.3.tar.bz2 1487754 BLAKE2B 272c76096f1f0690bead5472e949057959fc7c90558be7c96454f121a9c427494490b4aaf64c6490fe9df0a1de131e630b2cc0ae1310f8dfb7057d573a55f39f SHA512 a2c841e971a0a67bb81697c7e31568026d90b185a7acc93bd39b22f3f4b3670b15f6b798b6658dee4b9bb44df1a5a2b4985e743cc36dc11dbb047baa816f1941
+DIST xfce4-settings-4.16.0.tar.bz2 1492754 BLAKE2B 10bfa7ce556547a4a41e1a3691ea3e41b9de57bd21760a91424cd27469917264ce00ae7324ee1d81bdf27f6b275415af932d63aeba4e80de729e42df1cbff488 SHA512 38c06e4d4c0963019c20a3afadb0dc1bde8d1b477bcff2d0253e29beb5e4a8b5ae9d058b544cec6fe2bfc2c1d44f74283c94538eda25436d58db0754f112a238
diff --git a/xfce-base/xfce4-settings/xfce4-settings-4.16.0.ebuild b/xfce-base/xfce4-settings/xfce4-settings-4.16.0.ebuild
new file mode 100644
index 000000000000..add5c079f9ab
--- /dev/null
+++ b/xfce-base/xfce4-settings/xfce4-settings-4.16.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+inherit python-single-r1 xdg-utils
+
+DESCRIPTION="Configuration system for the Xfce desktop environment"
+HOMEPAGE="https://www.xfce.org/projects/"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="colord input_devices_libinput libcanberra libnotify upower +xklavier"
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ >=dev-libs/glib-2.50
+ media-libs/fontconfig
+ >=x11-libs/gtk+-3.20:3
+ x11-libs/libX11
+ >=x11-libs/libXcursor-1.1
+ >=x11-libs/libXi-1.3
+ >=x11-libs/libXrandr-1.2
+ >=xfce-base/garcon-0.2:=
+ >=xfce-base/exo-4.15.1:=
+ >=xfce-base/libxfce4ui-4.15.1:=
+ >=xfce-base/libxfce4util-4.15.2:=
+ >=xfce-base/xfconf-4.13:=
+ colord? ( x11-misc/colord:= )
+ libcanberra? ( >=media-libs/libcanberra-0.25[sound] )
+ input_devices_libinput? ( x11-drivers/xf86-input-libinput )
+ libnotify? ( >=x11-libs/libnotify-0.7 )
+ upower? ( >=sys-power/upower-0.9.23 )
+ xklavier? ( >=x11-libs/libxklavier-5 )
+ !<xfce-base/exo-4.15.1"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/gdbus-codegen
+ dev-util/intltool
+ virtual/pkgconfig
+ sys-devel/gettext
+ x11-base/xorg-proto"
+
+src_configure() {
+ local myconf=(
+ $(use_enable upower upower-glib)
+ $(use_enable input_devices_libinput xorg-libinput)
+ $(use_enable libnotify)
+ $(use_enable colord)
+ $(use_enable xklavier libxklavier)
+ $(use_enable libcanberra sound-settings)
+ )
+ econf "${myconf[@]}"
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}