summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-12 14:18:42 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-12 14:46:46 +0200
commit2cf8b44d8cd196b2a14e3aa011749950fac1597a (patch)
tree350c37a29be1e1d75b5375e5abd71eed3b27b4e3 /xfce-base
parentdev-libs/efl: drop 1.25.1-r10 (diff)
downloadgentoo-2cf8b44d8cd196b2a14e3aa011749950fac1597a.tar.gz
gentoo-2cf8b44d8cd196b2a14e3aa011749950fac1597a.tar.bz2
gentoo-2cf8b44d8cd196b2a14e3aa011749950fac1597a.zip
xfce-base/exo: Bump to 4.16.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/exo/Manifest1
-rw-r--r--xfce-base/exo/exo-4.16.2.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/xfce-base/exo/Manifest b/xfce-base/exo/Manifest
index 68db09005cf0..e3750c880d2f 100644
--- a/xfce-base/exo/Manifest
+++ b/xfce-base/exo/Manifest
@@ -1,2 +1,3 @@
DIST exo-4.16.0.tar.bz2 966143 BLAKE2B ee2175d2d5087e948a6fb9bd4ffed2ecfe54be7078d2f1c55a6b30a0f3920689a46372af749035b1454e74ef5c75037996f3601d76adf1d0067eceba6775df76 SHA512 8fff640c4a229e77911cf091866f265e1f0d7f0b9274b1a879f46061644dd6aec07ae3f8fc43ac7277429ea98bdde8d0ee010da7ed398cddc7d755fea91b964c
DIST exo-4.16.1.tar.bz2 880947 BLAKE2B d21509d15275d98a0b99acc6e101aad1423a859f0430957d5ce2b6c693ae0d189010d6cb8500b8d4f364edb3de787f4ee33ca4d1735d8c8fe7f8ad016027a799 SHA512 692d1c5adf58704546c580c1959b893ef20503180620b731444e29d534407515067b892736ad5ed904d3dbf480fbee7df9f36725b003067272c973f6ac8279d7
+DIST exo-4.16.2.tar.bz2 881098 BLAKE2B df1ad499becd22087724abb716d07a50e432ec555d03a3892d0b81745045c334cb3705419e901697e4c3bc10328837b4f5c4055800d1b6c79c9cfc503427643b SHA512 9c1252d78f5bb900254841a79f1c1b952cb60d9d0197e184266c35a86c340140cdff2460fa83f6fabb66380e2b3d7ab8a08719b4f4784d2215dde51410ce33e8
diff --git a/xfce-base/exo/exo-4.16.2.ebuild b/xfce-base/exo/exo-4.16.2.ebuild
new file mode 100644
index 000000000000..2cfa5d5ce161
--- /dev/null
+++ b/xfce-base/exo/exo-4.16.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools xdg-utils
+
+DESCRIPTION="Extensions, widgets and framework library with session support for Xfce"
+HOMEPAGE="https://www.xfce.org/projects/"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
+
+RDEPEND=">=dev-libs/glib-2.50
+ >=x11-libs/gtk+-3.22:3
+ >=xfce-base/libxfce4ui-4.15.1:=[gtk3(+)]
+ >=xfce-base/libxfce4util-4.12:="
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/gtk-doc-am
+ dev-util/intltool
+ >=dev-util/xfce4-dev-tools-4.16.0
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-4.16.0-allow-cross.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}