summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-12 17:07:04 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-12 17:16:01 +0200
commit2d6f1e810ce036faa281757a1137afd151481e3f (patch)
tree5709a8981d9861fb8ab7f89f6487674d11f6e7b4 /xfce-base
parentmail-client/thunderbird-bin: security cleanup (diff)
downloadgentoo-2d6f1e810ce036faa281757a1137afd151481e3f.tar.gz
gentoo-2d6f1e810ce036faa281757a1137afd151481e3f.tar.bz2
gentoo-2d6f1e810ce036faa281757a1137afd151481e3f.zip
xfce-base/xfce4-settings: Bump to 4.16.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/xfce4-settings/Manifest1
-rw-r--r--xfce-base/xfce4-settings/xfce4-settings-4.16.1.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/xfce-base/xfce4-settings/Manifest b/xfce-base/xfce4-settings/Manifest
index c617287c63c3..0595492a2625 100644
--- a/xfce-base/xfce4-settings/Manifest
+++ b/xfce-base/xfce4-settings/Manifest
@@ -1 +1,2 @@
DIST xfce4-settings-4.16.0.tar.bz2 1492754 BLAKE2B 10bfa7ce556547a4a41e1a3691ea3e41b9de57bd21760a91424cd27469917264ce00ae7324ee1d81bdf27f6b275415af932d63aeba4e80de729e42df1cbff488 SHA512 38c06e4d4c0963019c20a3afadb0dc1bde8d1b477bcff2d0253e29beb5e4a8b5ae9d058b544cec6fe2bfc2c1d44f74283c94538eda25436d58db0754f112a238
+DIST xfce4-settings-4.16.1.tar.bz2 1496053 BLAKE2B dd4176a5edc6a52c885ec80d4f5855ba7ea0ed6a70180f8b15d9754a246a097c82eeba4fb52b3ff1f551c905c21073c153fac3a4c47259710fae9cef8a95f45e SHA512 0f918ea61dfa71816366663114250ca97bb7e41f3cbd0e569b12e8271641f1b2b622ad17f9a185a30f638093328db0c6d175b7e7d03de56963b19e44eb29383c
diff --git a/xfce-base/xfce4-settings/xfce4-settings-4.16.1.ebuild b/xfce-base/xfce4-settings/xfce4-settings-4.16.1.ebuild
new file mode 100644
index 000000000000..1d3bec2bcf6b
--- /dev/null
+++ b/xfce-base/xfce4-settings/xfce4-settings-4.16.1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+inherit python-single-r1 xdg-utils
+
+DESCRIPTION="Configuration system for the Xfce desktop environment"
+HOMEPAGE="https://www.xfce.org/projects/"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="colord input_devices_libinput libcanberra libnotify upower +xklavier"
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ >=dev-libs/glib-2.50
+ media-libs/fontconfig
+ >=x11-libs/gtk+-3.20:3
+ x11-libs/libX11
+ >=x11-libs/libXcursor-1.1
+ >=x11-libs/libXi-1.3
+ >=x11-libs/libXrandr-1.2
+ >=xfce-base/garcon-0.2:=
+ >=xfce-base/exo-4.15.1:=
+ >=xfce-base/libxfce4ui-4.15.1:=
+ >=xfce-base/libxfce4util-4.15.2:=
+ >=xfce-base/xfconf-4.13:=
+ colord? ( x11-misc/colord:= )
+ libcanberra? ( >=media-libs/libcanberra-0.25[sound] )
+ input_devices_libinput? ( x11-drivers/xf86-input-libinput )
+ libnotify? ( >=x11-libs/libnotify-0.7 )
+ upower? ( >=sys-power/upower-0.9.23 )
+ xklavier? ( >=x11-libs/libxklavier-5 )
+ !<xfce-base/exo-4.15.1"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/gdbus-codegen
+ dev-util/intltool
+ virtual/pkgconfig
+ sys-devel/gettext
+ x11-base/xorg-proto"
+
+src_configure() {
+ local myconf=(
+ $(use_enable upower upower-glib)
+ $(use_enable input_devices_libinput xorg-libinput)
+ $(use_enable libnotify)
+ $(use_enable colord)
+ $(use_enable xklavier libxklavier)
+ $(use_enable libcanberra sound-settings)
+ )
+ econf "${myconf[@]}"
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}