summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-17 15:21:25 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-17 15:49:54 +0200
commit4048b738e5fb877c8a9690f9cb6400d7ca1a5be0 (patch)
tree0121dea3ecf0bd0da447848491db9bc8903b7037 /xfce-base
parentxfce-base/xfconf: Bump to 4.19.0 (diff)
downloadgentoo-4048b738e5fb877c8a9690f9cb6400d7ca1a5be0.tar.gz
gentoo-4048b738e5fb877c8a9690f9cb6400d7ca1a5be0.tar.bz2
gentoo-4048b738e5fb877c8a9690f9cb6400d7ca1a5be0.zip
xfce-base/tumbler: Bump to 4.19.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/tumbler/Manifest1
-rw-r--r--xfce-base/tumbler/tumbler-4.19.0.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/xfce-base/tumbler/Manifest b/xfce-base/tumbler/Manifest
index 269f25278449..df80582e4055 100644
--- a/xfce-base/tumbler/Manifest
+++ b/xfce-base/tumbler/Manifest
@@ -1,2 +1,3 @@
DIST tumbler-4.18.0.tar.bz2 609664 BLAKE2B f18c8786b0dee452526b1fda34c6a1d442655d8c252cb68cb1593c121fb2daaee520cc7958936e6ba0492b2eddacb7722fde937092bdde91ca34d4ca3ab42667 SHA512 60f0621ab1a7a00909ea04181c7dfb733dfbb33219991b2f81f991c289428e026993639ee1ffa5b46dd6f35866e0a3ad76fadbd11eec5fa926fba0da2278b99f
DIST tumbler-4.18.1.tar.bz2 613283 BLAKE2B 8473e263dbecc8df40184d6cfce49b300799e576884372fbd285858da834e6b6e76f5fda23e5965660a596210ad1e86a936e5e6f1a1d7aafbc8b8467769cf35d SHA512 5b781e4a53b5a1f210ee9d373d4a1e26864d6c6afe64e056267c7ffb5e4ac77f56e0fe2c4e5cefccb1910041af0ee2828a2f62b4ab86a689eca9a5b30ab6048d
+DIST tumbler-4.19.0.tar.bz2 692513 BLAKE2B 6b391cf11670dc0dca582ae5052e9d5dc0f8e240c75f14a52ee17f6779a9f0ccc1daf43cb4fad6eff92d6ac52424c769b3e21785b7c743a003340303d9a2d76c SHA512 62fb373f9f9b6d186d9d64a8f4d94a4dc57840e231749b6a0458d582bd205f29c837983901caf53a698ed44667b9e12a000d8dfbbbe9c2e3224622ae41a560e7
diff --git a/xfce-base/tumbler/tumbler-4.19.0.ebuild b/xfce-base/tumbler/tumbler-4.19.0.ebuild
new file mode 100644
index 000000000000..14533c164435
--- /dev/null
+++ b/xfce-base/tumbler/tumbler-4.19.0.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="A thumbnail service for Thunar"
+HOMEPAGE="
+ https://docs.xfce.org/xfce/tumbler/start
+ https://gitlab.xfce.org/xfce/tumbler/
+"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="curl epub ffmpeg gstreamer jpeg odf pdf raw"
+
+DEPEND="
+ >=dev-libs/glib-2.66.0
+ media-libs/freetype:2=
+ media-libs/libpng:0=
+ >=sys-apps/dbus-1.6
+ >=xfce-base/libxfce4util-4.17.1:=
+ >=x11-libs/gdk-pixbuf-2.40.0
+ curl? ( >=net-misc/curl-7.32.0:= )
+ epub? ( app-text/libgepub )
+ ffmpeg? ( >=media-video/ffmpegthumbnailer-2.0.8:= )
+ gstreamer? (
+ media-libs/gstreamer:1.0
+ media-libs/gst-plugins-base:1.0
+ )
+ jpeg? ( media-libs/libjpeg-turbo:0= )
+ odf? ( >=gnome-extra/libgsf-1.14.20:= )
+ pdf? ( >=app-text/poppler-0.12.4[cairo] )
+ raw? ( >=media-libs/libopenraw-0.0.8:=[gtk] )
+"
+RDEPEND="
+ ${DEPEND}
+ gstreamer? ( media-plugins/gst-plugins-meta:1.0 )
+"
+BDEPEND="
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ dev-util/gtk-doc-am
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local myconf=(
+ $(use_enable curl cover-thumbnailer)
+ $(use_enable epub gepub-thumbnailer)
+ $(use_enable jpeg jpeg-thumbnailer)
+ $(use_enable ffmpeg ffmpeg-thumbnailer)
+ $(use_enable gstreamer gstreamer-thumbnailer)
+ $(use_enable odf odf-thumbnailer)
+ $(use_enable pdf poppler-thumbnailer)
+ $(use_enable raw raw-thumbnailer)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}