summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-08-12 16:08:44 +0200
committerMichał Górny <mgorny@gentoo.org>2020-08-12 16:10:26 +0200
commit4a5285790b11c0714fd5fc2782ec64921b2d0cf9 (patch)
tree2d070b68127f61d50497fd05735c6ea8471dbefa /xfce-base
parentxfce-base/xfwm4: Bump to 4.14.5 (diff)
downloadgentoo-4a5285790b11c0714fd5fc2782ec64921b2d0cf9.tar.gz
gentoo-4a5285790b11c0714fd5fc2782ec64921b2d0cf9.tar.bz2
gentoo-4a5285790b11c0714fd5fc2782ec64921b2d0cf9.zip
xfce-base/xfwm4: Bump to 4.15.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/xfwm4/Manifest1
-rw-r--r--xfce-base/xfwm4/xfwm4-4.15.1.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/xfce-base/xfwm4/Manifest b/xfce-base/xfwm4/Manifest
index 58d966f561aa..8a4394300b9a 100644
--- a/xfce-base/xfwm4/Manifest
+++ b/xfce-base/xfwm4/Manifest
@@ -3,3 +3,4 @@ DIST xfwm4-4.14.3.tar.bz2 1164653 BLAKE2B 24db309df708164bd0554fb96499205b4f1437
DIST xfwm4-4.14.4.tar.bz2 1164972 BLAKE2B 5bdf4837bd19708c975d6400750059c5182b9d1b1a0b7b30e8721e1c443d9f78c1ea1c868ad7ceb384e442b94139b89d50327dc6413e938348816a311cada2b2 SHA512 ca3c94d1835076b904aca9f531dccebd9d78a1c85e0f7af7ac7aaba1a067e0f11f5224bdc20dc233038dc752ae1ac85602608c168a4d91643ac7538b448c04bf
DIST xfwm4-4.14.5.tar.bz2 1165140 BLAKE2B 3f598b5cb8ce58a8aa4a4c82e53a5b02a870e26ddd0487796aeab86695c5dc6bc132daac32630dc109ec12dd10dab370a91c00dfbdf1109815cf5a9ae82fc88b SHA512 d2b5b198f3ffa91b0b07d5258f5f14f45e431fd7d992143bf9fc381f647ea0ee47ae447122ef8c7a40606c08955f83975fcff94b6f7ceb331a0a8681b57050fd
DIST xfwm4-4.15.0.tar.bz2 1179779 BLAKE2B c12ec365218b8afda7b01706d4f2822b4663d327aad482e89f8c8b2811b687594c6f58ea0b5be79eabe3771c125edb111c3b03a708dcfbf720eef993181b0e14 SHA512 8359c8e9414bc7a66a95c4b9eb98da7a3ba08c0e15752c2ebb4a569f9afcd50697d37685c786d6a4c23f1bfa12f8782293923fde309c7d027cf66dd4db44340e
+DIST xfwm4-4.15.1.tar.bz2 1179671 BLAKE2B c358f8050dd6fcc356c2d300dab959dbfb5f452484e0998b25755aa6c6dd1783ca117ba43f44e18a9555542a1794000a768765a5b98e1e381367260df1d503ba SHA512 ae4cea9da4bc852aa3ce19039b66cc05f7c7cabe07637837bf1a51c37b6c9536a46b6af85e9402c33578e8da305b28bac23792afa080076e625a7df9f769935c
diff --git a/xfce-base/xfwm4/xfwm4-4.15.1.ebuild b/xfce-base/xfwm4/xfwm4-4.15.1.ebuild
new file mode 100644
index 000000000000..77ed670eb91b
--- /dev/null
+++ b/xfce-base/xfwm4/xfwm4-4.15.1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils
+
+DESCRIPTION="Window manager for the Xfce desktop environment"
+HOMEPAGE="https://www.xfce.org/projects/"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="opengl startup-notification +xcomposite +xpresent"
+
+RDEPEND=">=dev-libs/glib-2.20
+ >=x11-libs/gtk+-3.20:3
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXinerama
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/libXres
+ x11-libs/pango
+ >=x11-libs/libwnck-3.14:3
+ >=xfce-base/libxfce4util-4.10:=
+ >=xfce-base/libxfce4ui-4.12:=
+ >=xfce-base/xfconf-4.13:=
+ opengl? ( media-libs/libepoxy:=[X(+)] )
+ startup-notification? ( x11-libs/startup-notification )
+ xpresent? ( x11-libs/libXpresent )
+ xcomposite? (
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXfixes
+ )"
+# libICE/libSM: not really used anywhere but checked by configure
+# https://bugzilla.xfce.org/show_bug.cgi?id=11914
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ x11-libs/libICE
+ x11-libs/libSM
+ xfce-base/exo
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog COMPOSITOR NEWS README TODO )
+
+src_configure() {
+ local myconf=(
+ $(use_enable opengl epoxy)
+ $(use_enable startup-notification)
+ --enable-xsync
+ --enable-render
+ --enable-randr
+ $(use_enable xpresent)
+ $(use_enable xcomposite compositor)
+ )
+
+ econf "${myconf[@]}"
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}