summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-08-12 13:41:58 +0200
committerMichał Górny <mgorny@gentoo.org>2019-08-12 15:20:15 +0200
commit6148d441909f1e6810583d5e51b41ed0d74b2585 (patch)
treebf7934d0eb8a695509fd1bf6a603a477a93ee1e1 /xfce-base
parentsys-devel/parity: add IUSE=+vc16_2 for Visual Studio 2019 (diff)
downloadgentoo-6148d441909f1e6810583d5e51b41ed0d74b2585.tar.gz
gentoo-6148d441909f1e6810583d5e51b41ed0d74b2585.tar.bz2
gentoo-6148d441909f1e6810583d5e51b41ed0d74b2585.zip
xfce-base/libxfce4ui: Bump to 4.14.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/libxfce4ui/Manifest1
-rw-r--r--xfce-base/libxfce4ui/libxfce4ui-4.14.1.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/xfce-base/libxfce4ui/Manifest b/xfce-base/libxfce4ui/Manifest
index 130c6401fb85..3754eba9ddca 100644
--- a/xfce-base/libxfce4ui/Manifest
+++ b/xfce-base/libxfce4ui/Manifest
@@ -1,3 +1,4 @@
DIST libxfce4ui-4.13.4.tar.bz2 684065 BLAKE2B 1da875832683b5e06b8e91b4078be8122ae85a91560d7b1768cb8c880fcf5e1d7cd07d24927ae3325ba9c500c6c2cd30e717e517775492b9948add0711f5aa40 SHA512 c82d6ff7ea0da4fc0f664bab92f1e9531162996a26bb092e6ba651cfc4551732cbcd8023908d428b47906c17c331c14bf4804256566ca564befa218dc1194206
DIST libxfce4ui-4.13.7.tar.bz2 738592 BLAKE2B e59727f05d4772a164ed097ad8629a7327a8a6eafb99d78f3aab093879195b20d2e7f7192dbc3f1c8df67836b98695d274e64744dc57271bd87f9cd1e6e50adc SHA512 bcee0bd7b1f1200c195809b8484778326d02637c06754e876d0fdcdfb860ea642fc342c3fc5cb4b181bfbd58f17a695cc1fa1b318725f774f3b79e544ee4b32d
DIST libxfce4ui-4.14.0.tar.bz2 756239 BLAKE2B 72a7ef23140c45cc71b077a5e5ec6e985b293fa4065a13fe648f81f05cf7e428657e9eed2f4339353cbe42979d84e8253c5518a345b1c2f509091899e4ed4053 SHA512 1d4ba1260547cde3960ea36f797b8b3fd14113f6f84363b429fb470879e9e9e835ada2be2071f7c53d7c6a8d631b460651f37cbcb232c2ca320ecaf6ba619be0
+DIST libxfce4ui-4.14.1.tar.bz2 756175 BLAKE2B d487cc0a04b6053ead6670eeb83cafe1c4098818d5ad6a94a81176720d78cfd65160156961cbb526baa1640ae66a5c6958f707b7078c412d81fcd24cc8cf4013 SHA512 f42f41da3a683a0c56c3b1e7ba420c4f50909d2613e681d053b09b50bc0eb7f750f44c892e94b0ee8b9207983a87c0cadbda1ad93d0df74ae351dc8812025407
diff --git a/xfce-base/libxfce4ui/libxfce4ui-4.14.1.ebuild b/xfce-base/libxfce4ui/libxfce4ui-4.14.1.ebuild
new file mode 100644
index 000000000000..e44453634d38
--- /dev/null
+++ b/xfce-base/libxfce4ui/libxfce4ui-4.14.1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils vala
+
+DESCRIPTION="Unified widget and session management libs for Xfce"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="LGPL-2+ GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="debug glade introspection startup-notification vala"
+REQUIRED_USE="vala? ( introspection )"
+
+RDEPEND=">=dev-libs/glib-2.42:2=
+ >=x11-libs/gtk+-2.24:2=
+ >=x11-libs/gtk+-3.18:3=[introspection?]
+ x11-libs/libX11:=
+ x11-libs/libICE:=
+ x11-libs/libSM:=
+ >=xfce-base/libxfce4util-4.12:=[introspection?]
+ >=xfce-base/xfconf-4.12:=
+ glade? ( dev-util/glade:3.10= )
+ introspection? ( dev-libs/gobject-introspection:= )
+ startup-notification? ( x11-libs/startup-notification:= )
+ !xfce-base/xfce-utils"
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )"
+
+src_prepare() {
+ # stupid vala.eclass...
+ default
+}
+
+src_configure() {
+ local myconf=(
+ $(use_enable introspection)
+ $(use_enable startup-notification)
+ $(use_enable vala)
+ # TODO: check revdeps and make it optional one day
+ --enable-gtk2
+ # requires deprecated glade:3 (gladeui-1.0), bug #551296
+ --disable-gladeui
+ # this one's for :3.10
+ $(use_enable glade gladeui2)
+ --with-vendor-info=Gentoo
+ )
+
+ use vala && vala_src_prepare
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}