summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-07 23:10:06 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-07 23:23:52 +0100
commit6963fdbcddbfd29fc0880f8dc55f2f43260c7936 (patch)
treed94a796527948969aaff6e57f3e04d8ac3ace63e /xfce-base
parentdev-ml/ocaml-stdint: some test fail (diff)
downloadgentoo-6963fdbcddbfd29fc0880f8dc55f2f43260c7936.tar.gz
gentoo-6963fdbcddbfd29fc0880f8dc55f2f43260c7936.tar.bz2
gentoo-6963fdbcddbfd29fc0880f8dc55f2f43260c7936.zip
xfce-base/exo: Bump to 4.16.3
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/exo/Manifest1
-rw-r--r--xfce-base/exo/exo-4.16.3.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/xfce-base/exo/Manifest b/xfce-base/exo/Manifest
index 9bce67adf196..975cf4df43fc 100644
--- a/xfce-base/exo/Manifest
+++ b/xfce-base/exo/Manifest
@@ -1,2 +1,3 @@
DIST exo-4.16.2.tar.bz2 881098 BLAKE2B df1ad499becd22087724abb716d07a50e432ec555d03a3892d0b81745045c334cb3705419e901697e4c3bc10328837b4f5c4055800d1b6c79c9cfc503427643b SHA512 9c1252d78f5bb900254841a79f1c1b952cb60d9d0197e184266c35a86c340140cdff2460fa83f6fabb66380e2b3d7ab8a08719b4f4784d2215dde51410ce33e8
+DIST exo-4.16.3.tar.bz2 885516 BLAKE2B 1689821fc8cc72fc848d627d2cccd886223740c2910ed2f42fa70545dfb604eb184d3cfbf6aa93e7723fcc59291e0c33f77e478429e1e4296b2243155e277604 SHA512 0dc4d2da6dd80a4c1b05a5316bb6e7ad02858d3fb49b666d6065bd7b11d7b8aed2732135eee8393185a0c321a242807d97b51f794186ce7a769ec2c9106ba8fd
DIST exo-4.17.1.tar.bz2 877757 BLAKE2B 152e168568f4ad12e1eb03f7b1971b3369647da0adac57f55d36fc176c36f7c2ccf9125f6bad386843753855b4bbb679a7a6abd80a9375d2212550e0987d4fa4 SHA512 597fee2cc0188159d5278bb5d547f1a4619645684ba3da4046946c5eb38b2a4913731e589caeeb2f8505516bdcbba64bee03291857215e2b4208aa3d2c563988
diff --git a/xfce-base/exo/exo-4.16.3.ebuild b/xfce-base/exo/exo-4.16.3.ebuild
new file mode 100644
index 000000000000..b4360fab3a1d
--- /dev/null
+++ b/xfce-base/exo/exo-4.16.3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools xdg-utils
+
+DESCRIPTION="Extensions, widgets and framework library with session support for Xfce"
+HOMEPAGE="https://www.xfce.org/projects/"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
+
+RDEPEND=">=dev-libs/glib-2.50
+ >=x11-libs/gtk+-3.22:3
+ >=xfce-base/libxfce4ui-4.15.1:=[gtk3(+)]
+ >=xfce-base/libxfce4util-4.12:="
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/gtk-doc-am
+ dev-util/intltool
+ >=dev-util/xfce4-dev-tools-4.16.0
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-4.16.0-allow-cross.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}