summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-05-02 18:56:00 +0200
committerMichał Górny <mgorny@gentoo.org>2019-05-02 19:07:11 +0200
commit6e9e7e8ff66149e1070ae67736b936ad39ca0478 (patch)
tree3946f7248db96ed319d114b57b402ab4e13e307b /xfce-base
parentxfce-base/exo: Bump to 0.12.5 (diff)
downloadgentoo-6e9e7e8ff66149e1070ae67736b936ad39ca0478.tar.gz
gentoo-6e9e7e8ff66149e1070ae67736b936ad39ca0478.tar.bz2
gentoo-6e9e7e8ff66149e1070ae67736b936ad39ca0478.zip
xfce-base/exo: Disable GTK+2 support in -r100
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/exo/exo-0.12.5-r100.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/xfce-base/exo/exo-0.12.5-r100.ebuild b/xfce-base/exo/exo-0.12.5-r100.ebuild
new file mode 100644
index 000000000000..5ce9384936af
--- /dev/null
+++ b/xfce-base/exo/exo-0.12.5-r100.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils
+
+DESCRIPTION="Extensions, widgets and framework library with session support for Xfce"
+HOMEPAGE="https://www.xfce.org/projects/"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND=">=dev-lang/perl-5.6
+ >=dev-libs/glib-2.42:=
+ dev-perl/URI
+ >=x11-libs/gtk+-3.22:3=
+ >=xfce-base/libxfce4ui-4.12:=[gtk3(+)]
+ >=xfce-base/libxfce4util-4.12:="
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_configure() {
+ local myconf=(
+ --disable-gtk2
+ )
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}