summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-04-18 18:06:03 +0200
committerMichał Górny <mgorny@gentoo.org>2023-04-18 18:14:31 +0200
commit7095525d2366d624e74784822cae17f38ae59fcd (patch)
treeb0e4da72fddfcf2776fd5fc5246766d4f3d0aaae /xfce-base
parentdev-lang/vala: Version bump to 0.56.7 (diff)
downloadgentoo-7095525d2366d624e74784822cae17f38ae59fcd.tar.gz
gentoo-7095525d2366d624e74784822cae17f38ae59fcd.tar.bz2
gentoo-7095525d2366d624e74784822cae17f38ae59fcd.zip
xfce-base/garcon: Bump to 4.19.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/garcon/Manifest1
-rw-r--r--xfce-base/garcon/garcon-4.19.0.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/xfce-base/garcon/Manifest b/xfce-base/garcon/Manifest
index 9a3e557a3838..c3eb8ede843b 100644
--- a/xfce-base/garcon/Manifest
+++ b/xfce-base/garcon/Manifest
@@ -1,2 +1,3 @@
DIST garcon-4.18.0.tar.bz2 550674 BLAKE2B 93bc218c4455c61109ee7086a8cb822aaa154aaebd082c10ae9fd551019bce0fe68a117552c05fbe3a97c671036b5306703ba3c320d9b886715a83fb038c95b0 SHA512 c4b49ba47ac33823199a68ef9bdcba3acfcedde62a96a8a8b3af2bb1f28b3a5fe3e960ee93bdb964fbc01b039047d77f58fbe5b1f9fbd2ccd3d3f968e416a55c
DIST garcon-4.18.1.tar.bz2 554562 BLAKE2B 395cc8f7c7029196f25ecb52d393989ab0df0d9ddd34ec1fc4b0a2ee46b1a059a87c75797adb84d7557523e8e0c464278344fe3d793f05941a90874bdc8e036d SHA512 8e6d091beaf1aaa85cc16cd5e562191e0e6858a47444a23d95066f9afa3f8a70f7a61bc9fec33fe401945637e810441cbd6f961f41b40e2d2ce7a1ce4fce78a0
+DIST garcon-4.19.0.tar.bz2 648551 BLAKE2B 0084bf8b72fe1e3e2ac492c4639f84eb330ba37660adf0d5c3c41a4d9e6db3b063e4875f20dbe0a62b0c72bbb06072cb6cd37df057f6e5feb6431f35f87ea045 SHA512 c49304bc69528475318d934a4c565ade7171022f3887c7292e573ccd846137db1e7e325213a73b5a8003869adc35fa73cf5682ec646b2114f4614ae1c076ee9a
diff --git a/xfce-base/garcon/garcon-4.19.0.ebuild b/xfce-base/garcon/garcon-4.19.0.ebuild
new file mode 100644
index 000000000000..8464f7b5d0f4
--- /dev/null
+++ b/xfce-base/garcon/garcon-4.19.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="Xfce's freedesktop.org specification compatible menu implementation library"
+HOMEPAGE="
+ https://docs.xfce.org/xfce/garcon/start
+ https://gitlab.xfce.org/xfce/garcon/
+"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="LGPL-2+ FDL-1.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="introspection"
+
+DEPEND="
+ >=dev-libs/glib-2.66.0
+ >=x11-libs/gtk+-3.24.0:3
+ >=xfce-base/libxfce4util-4.15.6:=[introspection?]
+ >=xfce-base/libxfce4ui-4.15.7:=[introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-1.66:= )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-util/glib-utils
+ dev-util/gtk-doc-am
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ introspection? ( >=dev-libs/gobject-introspection-1.66 )
+"
+
+src_configure() {
+ local myconf=(
+ $(use_enable introspection)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}