summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-15 15:41:59 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-15 16:03:59 +0100
commit7d50336958010b91d6dd67a8675a093c62f636e1 (patch)
tree2d4a15550d5b826fe242ebc293bcb48f2a0d761f /xfce-base
parentxfce-base/xfwm4: Remove old (diff)
downloadgentoo-7d50336958010b91d6dd67a8675a093c62f636e1.tar.gz
gentoo-7d50336958010b91d6dd67a8675a093c62f636e1.tar.bz2
gentoo-7d50336958010b91d6dd67a8675a093c62f636e1.zip
xfce-base/xfwm4: Bump to 4.18.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/xfwm4/Manifest1
-rw-r--r--xfce-base/xfwm4/xfwm4-4.18.0.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/xfce-base/xfwm4/Manifest b/xfce-base/xfwm4/Manifest
index 68ff033d1b1c..fbfc53c25f63 100644
--- a/xfce-base/xfwm4/Manifest
+++ b/xfce-base/xfwm4/Manifest
@@ -1,2 +1,3 @@
DIST xfwm4-4.16.1.tar.bz2 1201722 BLAKE2B 4aae9b97095b423964a2ece7fe09b46ecfcea6688af6ab3b38ee34611cd68a7427597cb963b91b209d161c85aed552df15d005268bd8585d365b0cf63adf36b3 SHA512 f0d5d00e58202457d0d7d5f9772e7b2aa3f3339850065609baab7d379248a628d147464cc605698970134b87d58b7867b8c09d0a3a45ab84b2f3aa95be26f0b9
DIST xfwm4-4.17.2.tar.bz2 1220699 BLAKE2B 4bc011f17ee7fb662e4bb0c656056c45bfb2a07c4964cf9e7791fde35f5b2a072ed7ad8066305228c2af061caee8bf44488ffec0f98a0aba95d3d95fd30123d3 SHA512 2b0c45a5960fca4168431d8efdcaa6d6f22ad26949e40cbe54fb4895f185bb1180386ee61447a0255b3b723657a89b38e6f704d44490ab466be8631fd5494f62
+DIST xfwm4-4.18.0.tar.bz2 1220901 BLAKE2B 3a3db6368063b94fa46407fbf2173021a91efff04ed3d11c757d3e785de5e70289ae03e138e95979b3801a781c05d5f84b86b29727171796e1b80f874865bb36 SHA512 1003bb1ca5254221a5d56ffcb51c12cdef1b17b9d252622c6b18f3d3fbcf9d6e0e66b5f61e0f6eae6601ea3e50a70be98320e60d6738b04e44879e6f4e6da34d
diff --git a/xfce-base/xfwm4/xfwm4-4.18.0.ebuild b/xfce-base/xfwm4/xfwm4-4.18.0.ebuild
new file mode 100644
index 000000000000..350c367a5f0b
--- /dev/null
+++ b/xfce-base/xfwm4/xfwm4-4.18.0.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="Window manager for the Xfce desktop environment"
+HOMEPAGE="
+ https://docs.xfce.org/xfce/xfwm4/start
+ https://gitlab.xfce.org/xfce/xfwm4
+"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="opengl startup-notification +xcomposite +xpresent"
+
+DEPEND="
+ >=x11-libs/gtk+-3.24.0:3
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXinerama
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/libXres
+ x11-libs/pango
+ >=x11-libs/libwnck-3.14:3
+ >=xfce-base/libxfce4util-4.10:=
+ >=xfce-base/libxfce4ui-4.12:=
+ >=xfce-base/xfconf-4.13:=
+ opengl? ( media-libs/libepoxy:=[X(+)] )
+ startup-notification? ( x11-libs/startup-notification )
+ xcomposite? (
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXfixes
+ )
+ xpresent? ( x11-libs/libXpresent )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-libs/glib
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local myconf=(
+ $(use_enable opengl epoxy)
+ $(use_enable startup-notification)
+ $(use_enable xcomposite compositor)
+ $(use_enable xpresent)
+ --enable-randr
+ --enable-render
+ --enable-xi2
+ --enable-xsync
+ )
+
+ econf "${myconf[@]}"
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}