summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-12 12:04:35 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-12 12:07:23 +0100
commit8db7131e0147716deead55e7de331bd59b21fe08 (patch)
treeda5da6ddc39e8ec7eea36037637e14a5465ce564 /xfce-base
parentsys-fs/dd-rescue: Bump to version 1.99.10 (diff)
downloadgentoo-8db7131e0147716deead55e7de331bd59b21fe08.tar.gz
gentoo-8db7131e0147716deead55e7de331bd59b21fe08.tar.bz2
gentoo-8db7131e0147716deead55e7de331bd59b21fe08.zip
xfce-base/exo: Bump to 4.16.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/exo/Manifest1
-rw-r--r--xfce-base/exo/exo-4.16.1.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/xfce-base/exo/Manifest b/xfce-base/exo/Manifest
index 5a70eecc93aa..68db09005cf0 100644
--- a/xfce-base/exo/Manifest
+++ b/xfce-base/exo/Manifest
@@ -1 +1,2 @@
DIST exo-4.16.0.tar.bz2 966143 BLAKE2B ee2175d2d5087e948a6fb9bd4ffed2ecfe54be7078d2f1c55a6b30a0f3920689a46372af749035b1454e74ef5c75037996f3601d76adf1d0067eceba6775df76 SHA512 8fff640c4a229e77911cf091866f265e1f0d7f0b9274b1a879f46061644dd6aec07ae3f8fc43ac7277429ea98bdde8d0ee010da7ed398cddc7d755fea91b964c
+DIST exo-4.16.1.tar.bz2 880947 BLAKE2B d21509d15275d98a0b99acc6e101aad1423a859f0430957d5ce2b6c693ae0d189010d6cb8500b8d4f364edb3de787f4ee33ca4d1735d8c8fe7f8ad016027a799 SHA512 692d1c5adf58704546c580c1959b893ef20503180620b731444e29d534407515067b892736ad5ed904d3dbf480fbee7df9f36725b003067272c973f6ac8279d7
diff --git a/xfce-base/exo/exo-4.16.1.ebuild b/xfce-base/exo/exo-4.16.1.ebuild
new file mode 100644
index 000000000000..2cfa5d5ce161
--- /dev/null
+++ b/xfce-base/exo/exo-4.16.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools xdg-utils
+
+DESCRIPTION="Extensions, widgets and framework library with session support for Xfce"
+HOMEPAGE="https://www.xfce.org/projects/"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
+
+RDEPEND=">=dev-libs/glib-2.50
+ >=x11-libs/gtk+-3.22:3
+ >=xfce-base/libxfce4ui-4.15.1:=[gtk3(+)]
+ >=xfce-base/libxfce4util-4.12:="
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/gtk-doc-am
+ dev-util/intltool
+ >=dev-util/xfce4-dev-tools-4.16.0
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-4.16.0-allow-cross.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}