summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-23 00:23:13 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-23 00:35:42 +0100
commit966cae998ef95155fdf7fdf568a803be0dbda4a0 (patch)
tree30555c874bae037c1afda5ca2e9a5c21f46abdd3 /xfce-base
parentxfce-base/libxfce4util: Bump to 4.16.0 (diff)
downloadgentoo-966cae998ef95155fdf7fdf568a803be0dbda4a0.tar.gz
gentoo-966cae998ef95155fdf7fdf568a803be0dbda4a0.tar.bz2
gentoo-966cae998ef95155fdf7fdf568a803be0dbda4a0.zip
xfce-base/xfconf: Bump to 4.16.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/xfconf/Manifest1
-rw-r--r--xfce-base/xfconf/xfconf-4.16.0.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/xfce-base/xfconf/Manifest b/xfce-base/xfconf/Manifest
index feb1affb5777..6fac71ba39f1 100644
--- a/xfce-base/xfconf/Manifest
+++ b/xfce-base/xfconf/Manifest
@@ -3,3 +3,4 @@ DIST xfconf-4.14.3.tar.bz2 591432 BLAKE2B 9722547018a6db7132bad53b750ec8bd66b2f5
DIST xfconf-4.14.4.tar.bz2 592024 BLAKE2B 1432ca360fd1f02437f238f66906f15a8b98fd0e7f4525bc2b61d53b4e3c146a1a4f8480089956e0a2e5f88d952822ba2b151f54183619a88e3f14f747f6676e SHA512 2335c73078ec1b035ceb1d96a2e16d9e63ca7ad5cabac96478d134ad3f94c0e81351df8acd8fb446a97a56f30472502006d93e96acdafc69262af3bbb1fc79ad
DIST xfconf-4.15.0.tar.bz2 586244 BLAKE2B 0bc6331f6a00d9328b7d462da1bffd0aa57b7b6e5a48a6e9d05d43993910fe1a3677ca33ca2315caac0528087e61a66e574118efd6c9ea5fb2d068cc843532a8 SHA512 3d36881a5d4a8b514196905689f32eed0da49c642fced38c57fa9260013e2efc0ce83de502b91c5dd07734dd99c2521f2cac00b43d3d76141efe7eeddc03c5c7
DIST xfconf-4.15.1.tar.bz2 588820 BLAKE2B a269612366ec8bf23db5848e24ff566939e46e6ddbae1665ec9685c72ca913fb23bf2d8f97397422def4eeab9ad37eeb6f3d0b045b692370c299607ccf4bb323 SHA512 7f9d39ef12a92dfa8fa11a8ef59e99b75646b0caf0dfd8bd1e044bb78f5fcfc0160587b112634a7c8f8417788a14a73bbc0f134f0432c693183f7e82e2a21b47
+DIST xfconf-4.16.0.tar.bz2 634858 BLAKE2B 34a03e457934310d4750b0811ff3b6fbde0c786656c9cc1bb2dd733e0104c2ab3ff1834fefcea31a6711931406b8ab507a528596b598e92c401defb8e6d7715e SHA512 d2e6b272243d6eda71f42cb3df18cb9c0745a1864718639e9aa494902dfe5b4989b2761fee2195456e5725cad0f744978f9c95c6f01e48aa016a919ce3468344
diff --git a/xfce-base/xfconf/xfconf-4.16.0.ebuild b/xfce-base/xfconf/xfconf-4.16.0.ebuild
new file mode 100644
index 000000000000..c733a69d2aad
--- /dev/null
+++ b/xfce-base/xfconf/xfconf-4.16.0.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit bash-completion-r1 vala
+
+DESCRIPTION="A configuration management system for Xfce"
+HOMEPAGE="https://www.xfce.org/projects/"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0/3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-solaris"
+IUSE="debug introspection vala"
+REQUIRED_USE="vala? ( introspection )"
+
+RDEPEND=">=dev-libs/glib-2.50
+ sys-apps/dbus
+ >=xfce-base/libxfce4util-4.14:=
+ introspection? ( dev-libs/gobject-introspection:= )
+ !<xfce-base/xfce4-panel-4.13.1
+ !<xfce-base/xfce4-settings-4.13.1"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )"
+
+src_prepare() {
+ # stupid vala.eclass...
+ default
+}
+
+src_configure() {
+ local myconf=(
+ $(use_enable introspection)
+ $(use_enable vala)
+ $(use_enable debug checks)
+ --with-bash-completion-dir="$(get_bashcompdir)"
+ )
+
+ use vala && vala_src_prepare
+ econf "${myconf[@]}"
+}
+
+src_test() {
+ local service_dir=${HOME}/.local/share/dbus-1/services
+ mkdir -p "${service_dir}" || die
+ cat > "${service_dir}/org.xfce.Xfconf.service" <<-EOF || die
+ [D-BUS Service]
+ Name=org.xfce.Xfconf
+ Exec=${S}/xfconfd/xfconfd
+ EOF
+
+ (
+ # start isolated dbus session bus
+ dbus_data=$(dbus-launch --sh-syntax) || exit
+ eval "${dbus_data}"
+
+ # -j>1 often hangs
+ # https://gitlab.xfce.org/xfce/xfconf/-/issues/13
+ nonfatal emake -j1 check
+ ret=${?}
+
+ kill "${DBUS_SESSION_BUS_PID}"
+ exit "${ret}"
+ ) || die
+}
+
+src_install() {
+ default
+ find "${D}" -type f -name '*.la' -delete || die
+}