summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-07-28 16:51:11 +0200
committerMichał Górny <mgorny@gentoo.org>2019-07-28 17:43:08 +0200
commit9d46f2d4cb59df09377d90af6d51807a7b19f910 (patch)
tree9b7398145280162da22d02979df7387eef879ca1 /xfce-base
parentxfce-base/xfce4-panel: Drop old (diff)
downloadgentoo-9d46f2d4cb59df09377d90af6d51807a7b19f910.tar.gz
gentoo-9d46f2d4cb59df09377d90af6d51807a7b19f910.tar.bz2
gentoo-9d46f2d4cb59df09377d90af6d51807a7b19f910.zip
xfce-base/xfce4-panel: Bump to 4.13.7
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/xfce4-panel/Manifest1
-rw-r--r--xfce-base/xfce4-panel/xfce4-panel-4.13.7.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/xfce-base/xfce4-panel/Manifest b/xfce-base/xfce4-panel/Manifest
index a61681da22f1..3929dd3587a0 100644
--- a/xfce-base/xfce4-panel/Manifest
+++ b/xfce-base/xfce4-panel/Manifest
@@ -1,2 +1,3 @@
DIST xfce4-panel-4.12.2.tar.bz2 1167175 BLAKE2B 09d16c58bb2d78242069fc2191009af6bb737fd6571f7d9ceef4b2b2dc0f0be6fcdad17aa588f69573b9d7f62ca0c54ec712bd467ff793b6952ede733889136b SHA512 b455e28ecbd9e2fc152e1132a806307597157605fef19c61091fce90984b2eded2c0b691d1fa2475c218c9d0b12103e348e648a32d3e8d0aa9ca210b7ae36a9e
DIST xfce4-panel-4.13.6.tar.bz2 1279153 BLAKE2B dd340dc9f50f7aa7baeb441c22c3705666938638e7de70e8fe286ae4c6e15e156626a64940bccca00e5ded4046a6a2588972e0578929672dcd399dc5f1c7ea3b SHA512 affbf3ce5ba62f5a40ce01554ad0cae34ab57beabcaa674b0d134c515ed49e98bf4269f66f16faee33d2ebeb8254ef69642786d3bd5bbb1b7c2f28e2b344ebd5
+DIST xfce4-panel-4.13.7.tar.bz2 1288128 BLAKE2B 76ee79904a6f412ea42bb7d3261064c4b683fe52df1ac60dccbbae0585da97e86ee1d2a5cf9ac46ed1b66bb915e812965df8e1af16b8833e7cb431955ac4770f SHA512 916a60f9a8eadbce75d3833039c5e6bd2f8db06d60bcedde5f91ce77d0a8a005faf049c3c7832ec29c4441611a21155f864686b00ea9c11b2c476ac2eb471ceb
diff --git a/xfce-base/xfce4-panel/xfce4-panel-4.13.7.ebuild b/xfce-base/xfce4-panel/xfce4-panel-4.13.7.ebuild
new file mode 100644
index 000000000000..cd40513a3018
--- /dev/null
+++ b/xfce-base/xfce4-panel/xfce4-panel-4.13.7.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vala xdg-utils
+
+DESCRIPTION="Panel for the Xfce desktop environment"
+HOMEPAGE="https://www.xfce.org/projects/"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+ LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="introspection vala"
+REQUIRED_USE="vala? ( introspection )"
+
+RDEPEND=">=dev-libs/glib-2.42:=
+ >=x11-libs/cairo-1:=
+ >=x11-libs/gtk+-2.20:2=
+ >=x11-libs/gtk+-3.22:3=[introspection?]
+ x11-libs/libX11:=
+ x11-libs/libwnck:3=
+ >=xfce-base/exo-0.11.2:=
+ >=xfce-base/garcon-0.5:=
+ >=xfce-base/libxfce4ui-4.13:=
+ >=xfce-base/libxfce4util-4.13:=[introspection?]
+ >=xfce-base/xfconf-4.13:=
+ introspection? ( dev-libs/gobject-introspection:= )"
+DEPEND="${RDEPEND}
+ vala? ( $(vala_depend) )
+ dev-lang/perl
+ dev-util/gtk-doc-am
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_prepare() {
+ # stupid vala.eclass...
+ default
+}
+
+src_configure() {
+ local myconf=(
+ $(use_enable introspection)
+ $(use_enable vala)
+
+ # enable GTK+2 compatibility
+ --enable-gtk2
+ )
+
+ use vala && vala_src_prepare
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}