summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-01 14:47:08 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-01 14:47:08 +0100
commitdd0e4c8cf3f28cc4f9542f0d63e5cc0349f8acd4 (patch)
tree38283f75449ea1b4f5e2419fbaafe61938e2c1ec /xfce-base
parentxfce-base/thunar: Bump to 4.17.12 (diff)
downloadgentoo-dd0e4c8cf3f28cc4f9542f0d63e5cc0349f8acd4.tar.gz
gentoo-dd0e4c8cf3f28cc4f9542f0d63e5cc0349f8acd4.tar.bz2
gentoo-dd0e4c8cf3f28cc4f9542f0d63e5cc0349f8acd4.zip
xfce-base/xfwm4: Bump to 4.17.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/xfwm4/Manifest1
-rw-r--r--xfce-base/xfwm4/xfwm4-4.17.2.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/xfce-base/xfwm4/Manifest b/xfce-base/xfwm4/Manifest
index ecdb696b29e6..71dca1817fee 100644
--- a/xfce-base/xfwm4/Manifest
+++ b/xfce-base/xfwm4/Manifest
@@ -1,2 +1,3 @@
DIST xfwm4-4.16.1.tar.bz2 1201722 BLAKE2B 4aae9b97095b423964a2ece7fe09b46ecfcea6688af6ab3b38ee34611cd68a7427597cb963b91b209d161c85aed552df15d005268bd8585d365b0cf63adf36b3 SHA512 f0d5d00e58202457d0d7d5f9772e7b2aa3f3339850065609baab7d379248a628d147464cc605698970134b87d58b7867b8c09d0a3a45ab84b2f3aa95be26f0b9
DIST xfwm4-4.17.1.tar.bz2 1216851 BLAKE2B 7e9cc7b8c40d6f8b4945edc3f5b6663805e9b2ca7dc216c97e69431859d61fbdccc2833adb8cd171add2ef37bee85bafb983aa2ca048d6a1151a85e69debe6a4 SHA512 ebbf47630e56ff4438bfa642864dbc91fec9b35951489dd9a7b5ce12b6115a09314bfa6fe3ebd870fdde9cd31768483cd4098e6e36c95423711cda59b00703c2
+DIST xfwm4-4.17.2.tar.bz2 1220699 BLAKE2B 4bc011f17ee7fb662e4bb0c656056c45bfb2a07c4964cf9e7791fde35f5b2a072ed7ad8066305228c2af061caee8bf44488ffec0f98a0aba95d3d95fd30123d3 SHA512 2b0c45a5960fca4168431d8efdcaa6d6f22ad26949e40cbe54fb4895f185bb1180386ee61447a0255b3b723657a89b38e6f704d44490ab466be8631fd5494f62
diff --git a/xfce-base/xfwm4/xfwm4-4.17.2.ebuild b/xfce-base/xfwm4/xfwm4-4.17.2.ebuild
new file mode 100644
index 000000000000..b42e4331c03c
--- /dev/null
+++ b/xfce-base/xfwm4/xfwm4-4.17.2.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="Window manager for the Xfce desktop environment"
+HOMEPAGE="
+ https://docs.xfce.org/xfce/xfwm4/start
+ https://gitlab.xfce.org/xfce/xfwm4
+"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="opengl startup-notification +xcomposite +xpresent"
+
+DEPEND="
+ >=dev-libs/glib-2.20
+ >=x11-libs/gtk+-3.22:3
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXinerama
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ x11-libs/libXres
+ x11-libs/pango
+ >=x11-libs/libwnck-3.14:3
+ >=xfce-base/libxfce4util-4.10:=
+ >=xfce-base/libxfce4ui-4.12:=
+ >=xfce-base/xfconf-4.13:=
+ opengl? ( media-libs/libepoxy:=[X(+)] )
+ startup-notification? ( x11-libs/startup-notification )
+ xcomposite? (
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXfixes
+ )
+ xpresent? ( x11-libs/libXpresent )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local myconf=(
+ $(use_enable opengl epoxy)
+ $(use_enable startup-notification)
+ $(use_enable xcomposite compositor)
+ $(use_enable xpresent)
+ --enable-randr
+ --enable-render
+ --enable-xi2
+ --enable-xsync
+ )
+
+ econf "${myconf[@]}"
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}