summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-11-03 09:00:28 +0100
committerMichał Górny <mgorny@gentoo.org>2020-11-03 09:24:04 +0100
commitedac183a355766c43c6a51bf8fbbbdfcdbd74588 (patch)
tree6af41c233f9a98029eaf2e5f2c638c09028cfa0d /xfce-base
parentxfce-base/libxfce4ui: Bump to 4.15.4 (diff)
downloadgentoo-edac183a355766c43c6a51bf8fbbbdfcdbd74588.tar.gz
gentoo-edac183a355766c43c6a51bf8fbbbdfcdbd74588.tar.bz2
gentoo-edac183a355766c43c6a51bf8fbbbdfcdbd74588.zip
xfce-base/libxfce4util: Bump to 4.15.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/libxfce4util/Manifest1
-rw-r--r--xfce-base/libxfce4util/libxfce4util-4.15.4.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/xfce-base/libxfce4util/Manifest b/xfce-base/libxfce4util/Manifest
index e6db0e9b1fe1..d26de8e804ba 100644
--- a/xfce-base/libxfce4util/Manifest
+++ b/xfce-base/libxfce4util/Manifest
@@ -1,2 +1,3 @@
DIST libxfce4util-4.14.0.tar.bz2 516358 BLAKE2B d8e3d1e3247e23908456aa296415240c1a9146001a02cb859541922ee541e30955279fd68f2d9938e43f992a5115b21836363fa8d8234de87fca0bbaac830bf0 SHA512 6ac95aea03052d9e2f886cbe76afe9bbb43511bf3fe1766097e10cd8762541ed17060a727df3ef93e226aae448c15d9dd3ad8acd55a9d5f2387cb360bdf72832
DIST libxfce4util-4.15.3.tar.bz2 521420 BLAKE2B a6d0d5e56c32c3e6950af26da12ad54d94e2cd9d7e172167e43a5c4d262709b2972e1a29e9fb348ac12d8e72568330449fc279a701dd9fe9e98a788cffd33b23 SHA512 1754cc5f4582151a1eb381606d32b0744193982177165e2b227655790849f9799a53739f1c36ed31b1a77cab28526d22e3cb6dab401e4a3b8ff29f1d2ea885ba
+DIST libxfce4util-4.15.4.tar.bz2 527128 BLAKE2B 96825cc800becf4ec227d754ee53d244ad2f615c4a918d5bd88f42157bcd97e6e50d8162a35506ed531ed68da07a485e68758c702a4727eec76cacbf9ef4f817 SHA512 f18c6996c68925b3f8bb457225e6540881e62f8c524245d900f5d443fb1b5ff603afb536f0247e0d8b772df421225daea8184c1ac3c9b1228e53be12563ed468
diff --git a/xfce-base/libxfce4util/libxfce4util-4.15.4.ebuild b/xfce-base/libxfce4util/libxfce4util-4.15.4.ebuild
new file mode 100644
index 000000000000..dd5b8e34dae7
--- /dev/null
+++ b/xfce-base/libxfce4util/libxfce4util-4.15.4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vala
+
+DESCRIPTION="A basic utility library for the Xfce desktop environment"
+HOMEPAGE="https://git.xfce.org/xfce/libxfce4util/"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="LGPL-2+ GPL-2+"
+SLOT="0/7"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
+IUSE="introspection vala"
+REQUIRED_USE="vala? ( introspection )"
+
+RDEPEND=">=dev-libs/glib-2.42
+ introspection? ( dev-libs/gobject-introspection:= )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ dev-util/gtk-doc-am
+ sys-devel/gettext
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )"
+
+src_prepare() {
+ # stupid vala.eclass...
+ default
+}
+
+src_configure() {
+ local myconf=(
+ $(use_enable introspection)
+ $(use_enable vala)
+ )
+
+ use vala && vala_src_prepare
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+
+ find "${D}" -name '*.la' -delete || die
+}