summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /xfce-extra/multiload-nandhp
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'xfce-extra/multiload-nandhp')
-rw-r--r--xfce-extra/multiload-nandhp/Manifest2
-rw-r--r--xfce-extra/multiload-nandhp/metadata.xml14
-rw-r--r--xfce-extra/multiload-nandhp/multiload-nandhp-0.2.ebuild52
-rw-r--r--xfce-extra/multiload-nandhp/multiload-nandhp-0.3.ebuild46
4 files changed, 114 insertions, 0 deletions
diff --git a/xfce-extra/multiload-nandhp/Manifest b/xfce-extra/multiload-nandhp/Manifest
new file mode 100644
index 000000000000..095370ea7625
--- /dev/null
+++ b/xfce-extra/multiload-nandhp/Manifest
@@ -0,0 +1,2 @@
+DIST multiload-nandhp-0.2.tar.gz 32910 SHA256 3f8169522179f804470ed697fbb3c1213e6a1ada832fa45caac64e5698a17852 SHA512 07665b5d43f495e03553e0ae5ab6d2cdc46caa65a4336b824d36a7f9269313d1a3783a0fe48135f47cee14e76790ec8b1ce5948638fccc84f7b2157cdb07bee5 WHIRLPOOL 1146308c7d59eb6f461f96d79e273ccba06144ff47c4d9077e2a9015f39bcaab32f81e178651ce7bfb3b88978fcab5ae5f4199491112f3880b143761c24d68f5
+DIST multiload-nandhp-0.3.tar.gz 34812 SHA256 6ede95477422c94cd12c7999d7f3c4c3a7cf1db70999dd0dc50f3a44762290c7 SHA512 68367d0bca144a9c2c56516254b9f1531aedfbc0c34f924e0264314cd9a1215a13d1b3b6f1d3c1b0781a95abfa0705819e7d886e3c3b84705c3b5b60f7d5806c WHIRLPOOL 74254cc52a1f2ef4c73d1069ca408cf2e374062c254300e2fb9a3bcaafd44e6cc22d2c7d0a53fd70b15b930681df5b908a9e245ad9d6891c526b0267a5348e27
diff --git a/xfce-extra/multiload-nandhp/metadata.xml b/xfce-extra/multiload-nandhp/metadata.xml
new file mode 100644
index 000000000000..fed5a18cb79c
--- /dev/null
+++ b/xfce-extra/multiload-nandhp/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>xfce@gentoo.org</email>
+ <name>XFCE Team</name>
+ </maintainer>
+ <use>
+ <flag name="lxpanel">Build the applet for <pkg>lxde-base/lxpanel</pkg>, you can set XFCE_PLUGINS="" if you don't want the Xfce dependencies.</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">nandhp/multiload-nandhp</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/xfce-extra/multiload-nandhp/multiload-nandhp-0.2.ebuild b/xfce-extra/multiload-nandhp/multiload-nandhp-0.2.ebuild
new file mode 100644
index 000000000000..98e2a8e7b4a5
--- /dev/null
+++ b/xfce-extra/multiload-nandhp/multiload-nandhp-0.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils
+
+MY_PV=version-${PV/./-}
+
+DESCRIPTION="A port of the GNOME multiload applet for the Xfce and LXDE panels"
+HOMEPAGE="http://github.com/nandhp/multiload-nandhp"
+SRC_URI="http://github.com/nandhp/${PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 x86"
+IUSE="lxpanel +xfce_plugins_multiload-nandhp"
+
+RDEPEND=">=x11-libs/gtk+-2.14:2
+ x11-libs/cairo
+ >=gnome-base/libgtop-2.11.92
+ lxpanel? ( lxde-base/lxpanel )
+ xfce_plugins_multiload-nandhp? (
+ >=xfce-base/libxfce4ui-4.10
+ >=xfce-base/libxfce4util-4.10
+ >=xfce-base/xfce4-panel-4.10
+ )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+REQUIRED_USE="|| ( xfce_plugins_multiload-nandhp lxpanel )"
+
+DOCS="AUTHORS README.md"
+
+S=${WORKDIR}/${PN}-${MY_PV}
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_with xfce_plugins_multiload-nandhp xfce4) \
+ $(use_with lxpanel)
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}
diff --git a/xfce-extra/multiload-nandhp/multiload-nandhp-0.3.ebuild b/xfce-extra/multiload-nandhp/multiload-nandhp-0.3.ebuild
new file mode 100644
index 000000000000..ee1a57217a98
--- /dev/null
+++ b/xfce-extra/multiload-nandhp/multiload-nandhp-0.3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils
+
+MY_PV=version-${PV/./-}
+
+DESCRIPTION="A port of the GNOME multiload applet for the Xfce panel"
+HOMEPAGE="http://github.com/nandhp/multiload-nandhp"
+SRC_URI="http://github.com/nandhp/${PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=x11-libs/gtk+-2.14:2=
+ x11-libs/cairo:=
+ >=gnome-base/libgtop-2.11.92:=
+ >=xfce-base/libxfce4ui-4.10:=
+ >=xfce-base/libxfce4util-4.10:=
+ >=xfce-base/xfce4-panel-4.10:="
+
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+DOCS="AUTHORS README.md"
+
+S=${WORKDIR}/${PN}-${MY_PV}
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf --with-xfce4
+}
+
+src_install() {
+ default
+ prune_libtool_files --all
+}