summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /xfce-extra/xfce4-clipman-plugin
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'xfce-extra/xfce4-clipman-plugin')
-rw-r--r--xfce-extra/xfce4-clipman-plugin/Manifest1
-rw-r--r--xfce-extra/xfce4-clipman-plugin/metadata.xml11
-rw-r--r--xfce-extra/xfce4-clipman-plugin/xfce4-clipman-plugin-1.2.6.ebuild41
3 files changed, 53 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-clipman-plugin/Manifest b/xfce-extra/xfce4-clipman-plugin/Manifest
new file mode 100644
index 000000000000..e16aa742628a
--- /dev/null
+++ b/xfce-extra/xfce4-clipman-plugin/Manifest
@@ -0,0 +1 @@
+DIST xfce4-clipman-plugin-1.2.6.tar.bz2 438346 SHA256 23043f99c3e5257d1f3d68b5ee5125e3469c15620d098e22c6250386197f48a5 SHA512 fc6b4cee1990ff13f4c0050ebf3e4b69fc0f7124fa2dd9b41933ce11449d322fad666b1af82bd610ce2add28d012a7dddc345be4afa1432bb330ecd6344a168e WHIRLPOOL 6fa94e6e364c1a10e9de6cd80a1fad889a411ea3ca533647bf10f73967c60f1ad10caeefb0e838977b2b01f550a88561b196eba1f42949f00edb76103ec8ed2c
diff --git a/xfce-extra/xfce4-clipman-plugin/metadata.xml b/xfce-extra/xfce4-clipman-plugin/metadata.xml
new file mode 100644
index 000000000000..7eada0009129
--- /dev/null
+++ b/xfce-extra/xfce4-clipman-plugin/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>xfce@gentoo.org</email>
+ <name>XFCE Team</name>
+ </maintainer>
+ <use>
+ <flag name='qrcode'>Enable support for <pkg>media-gfx/qrencode</pkg></flag>
+ </use>
+</pkgmetadata>
diff --git a/xfce-extra/xfce4-clipman-plugin/xfce4-clipman-plugin-1.2.6.ebuild b/xfce-extra/xfce4-clipman-plugin/xfce4-clipman-plugin-1.2.6.ebuild
new file mode 100644
index 000000000000..0b4e946d3d05
--- /dev/null
+++ b/xfce-extra/xfce4-clipman-plugin/xfce4-clipman-plugin-1.2.6.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit xfconf
+
+DESCRIPTION="A clipboard manager plug-in for the Xfce panel"
+HOMEPAGE="http://goodies.xfce.org/projects/panel-plugins/xfce4-clipman-plugin"
+SRC_URI="mirror://xfce/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm hppa ~ia64 ppc ppc64 ~sparc x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux"
+IUSE="debug qrcode"
+
+RDEPEND=">=dev-libs/glib-2.18
+ dev-libs/libunique:1
+ >=x11-libs/gtk+-2.14:2
+ x11-libs/libXtst
+ >=xfce-base/exo-0.10
+ >=xfce-base/libxfce4ui-4.10
+ >=xfce-base/libxfce4util-4.10
+ >=xfce-base/xfce4-panel-4.10
+ >=xfce-base/xfconf-4.10
+ qrcode? ( >=media-gfx/qrencode-3.3.0 )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+ x11-proto/xproto"
+
+pkg_setup() {
+ XFCONF=(
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+ $(use_enable qrcode libqrencode)
+ $(xfconf_use_debug)
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS README )
+}