summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Dupeyron <calchan@gentoo.org>2018-04-02 14:24:32 -0600
committerDenis Dupeyron <calchan@gentoo.org>2018-04-02 14:26:55 -0600
commitac4fd56ccc61a47e961c17100e2ff95f8acaf9be (patch)
treeab4f50e1cfa95edb852f0567f25537f5443e5e01 /xfce-extra/xfce4-composite-editor/xfce4-composite-editor-0-r1.ebuild
parentkde-misc/skanlite: Drop 2.1.0 (diff)
downloadgentoo-ac4fd56ccc61a47e961c17100e2ff95f8acaf9be.tar.gz
gentoo-ac4fd56ccc61a47e961c17100e2ff95f8acaf9be.tar.bz2
gentoo-ac4fd56ccc61a47e961c17100e2ff95f8acaf9be.zip
xfce-extra/xfce4-composite-editor: remove obsolete xfconf.eclass migrate to EAPI6
Diffstat (limited to 'xfce-extra/xfce4-composite-editor/xfce4-composite-editor-0-r1.ebuild')
-rw-r--r--xfce-extra/xfce4-composite-editor/xfce4-composite-editor-0-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-composite-editor/xfce4-composite-editor-0-r1.ebuild b/xfce-extra/xfce4-composite-editor/xfce4-composite-editor-0-r1.ebuild
new file mode 100644
index 000000000000..1e3d989c39b4
--- /dev/null
+++ b/xfce-extra/xfce4-composite-editor/xfce4-composite-editor-0-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit desktop
+
+MY_PN=Xfce4-Composite-Editor
+
+DESCRIPTION="An graphical interface to modify composite settings"
+HOMEPAGE="http://keithhedger.hostingsiteforfree.com/pages/apps.html#xfcecomp"
+SRC_URI="http://keithhedger.hostingsiteforfree.com/zips/${MY_PN}.tar.gz -> ${MY_PN}-${PV}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="app-shells/bash:*
+ >=x11-misc/gtkdialog-0.8"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}
+
+src_prepare() {
+ eapply -p0 "${FILESDIR}"/${PN}-0-validate.patch
+ default
+}
+
+src_install() {
+ dobin xfce4-composite-editor
+ domenu xfcecomped.desktop
+ dodoc README
+}