summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-06-23 05:35:40 +0200
committerMichał Górny <mgorny@gentoo.org>2019-06-23 05:39:14 +0200
commit8e66bffdb4365c5ef15d8d335f15b0bd6b5bd8de (patch)
treec919dfd046a0ea4132b516c5d76d11f5591f57f9 /xfce-extra/xfce4-cpugraph-plugin
parentmedia-sound/xfmpc: Bump to 0.3.0 (diff)
downloadgentoo-8e66bffdb4365c5ef15d8d335f15b0bd6b5bd8de.tar.gz
gentoo-8e66bffdb4365c5ef15d8d335f15b0bd6b5bd8de.tar.bz2
gentoo-8e66bffdb4365c5ef15d8d335f15b0bd6b5bd8de.zip
xfce-extra/xfce4-cpugraph-plugin: Bump to 1.0.91
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra/xfce4-cpugraph-plugin')
-rw-r--r--xfce-extra/xfce4-cpugraph-plugin/Manifest1
-rw-r--r--xfce-extra/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin-1.0.91.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-cpugraph-plugin/Manifest b/xfce-extra/xfce4-cpugraph-plugin/Manifest
index 99230cd3b0de..1784b4ef0dca 100644
--- a/xfce-extra/xfce4-cpugraph-plugin/Manifest
+++ b/xfce-extra/xfce4-cpugraph-plugin/Manifest
@@ -1,2 +1,3 @@
DIST xfce4-cpugraph-plugin-1.0.5.tar.bz2 328972 BLAKE2B 7c39aa6fd9d0d6ecc5bedce1d99d330765c329d1fa673b61282fdea654ebd997caa118f57dd0776008584eaa2dbe0a6ae7df532ed3b941b03b111f5ae753d2e8 SHA512 3d1246958dd30638104f14a8b0078e25c05b67b42da953a97cb51d2b04e70d3f1da9d42ca4f4575b7114bce5abc4cb94d598737631536c0575b55d9a391e210a
DIST xfce4-cpugraph-plugin-1.0.90.tar.bz2 386127 BLAKE2B ec1809f64fa2fc142aa6efec315e2c138b7b49261ecce4735cc0dce225c24c69013f4b2a4250dcdf1513029765d81cb757e0bb38ebb3bd024b5b07fe2e0475d0 SHA512 7f2be5b41948ba4c730e6fd58038e96044ef8d007ae55f107a434308bfffc99071706c92854e41a589a807913fb98b9b216c141fc1d37c744275d5a3944aee09
+DIST xfce4-cpugraph-plugin-1.0.91.tar.bz2 377694 BLAKE2B da75c1295dc190923e1a16c2627fcb36517b00ded3a358c198152705ac220720b97db36a9e6b43c1efee11cbd95249acec38a0aa8985ce6b7d1e3c35a6d93d26 SHA512 513fdec6ed9c00b1f979c3ca9223667d7b50ccb55e9be9506497eade4d4495547e60e53507bf114aabd23af911a477f997c6f7c2944c1761125a12227c67ccf5
diff --git a/xfce-extra/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin-1.0.91.ebuild b/xfce-extra/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin-1.0.91.ebuild
new file mode 100644
index 000000000000..684e97eec64f
--- /dev/null
+++ b/xfce-extra/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin-1.0.91.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils
+
+DESCRIPTION="A system load plug-in for the Xfce panel"
+HOMEPAGE="https://goodies.xfce.org/projects/panel-plugins/xfce4-cpugraph-plugin"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="BSD-2 GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+
+RDEPEND=">=x11-libs/gtk+-3.22:3
+ >=xfce-base/libxfce4ui-4.12:=
+ >=xfce-base/xfce4-panel-4.12:="
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}