summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Dupeyron <calchan@gentoo.org>2017-11-17 22:08:51 +0000
committerDenis Dupeyron <calchan@gentoo.org>2017-11-17 22:08:51 +0000
commitc24c480bca34705387e280479a73e8e130cd1544 (patch)
treed2e3f86509aaaff3484b8ca9ae6b0e4697f94874 /xfce-extra/xfce4-indicator-plugin/xfce4-indicator-plugin-2.3.3-r2.ebuild
parentnet-dns/pdns-recursor: Version bump (diff)
downloadgentoo-c24c480bca34705387e280479a73e8e130cd1544.tar.gz
gentoo-c24c480bca34705387e280479a73e8e130cd1544.tar.bz2
gentoo-c24c480bca34705387e280479a73e8e130cd1544.zip
xfce4-indicator-plugin: remove obsolete xfconf.eclass, migrate to EAPI6
Package-Manager: Portage-2.3.14, Repoman-2.3.6
Diffstat (limited to 'xfce-extra/xfce4-indicator-plugin/xfce4-indicator-plugin-2.3.3-r2.ebuild')
-rw-r--r--xfce-extra/xfce4-indicator-plugin/xfce4-indicator-plugin-2.3.3-r2.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-indicator-plugin/xfce4-indicator-plugin-2.3.3-r2.ebuild b/xfce-extra/xfce4-indicator-plugin/xfce4-indicator-plugin-2.3.3-r2.ebuild
new file mode 100644
index 000000000000..1dd34e845cce
--- /dev/null
+++ b/xfce-extra/xfce4-indicator-plugin/xfce4-indicator-plugin-2.3.3-r2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit gnome2-utils xdg-utils
+
+DESCRIPTION="A panel plugin that uses indicator-applet to show new messages"
+HOMEPAGE="https://goodies.xfce.org/projects/panel-plugins/xfce4-indicator-plugin"
+SRC_URI="mirror://xfce/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/libindicator-12.10.1:3=
+ >=x11-libs/gtk+-3.6:3=
+ x11-libs/libX11:=
+ >=xfce-base/libxfce4ui-4.11:=[gtk3(+)]
+ >=xfce-base/libxfce4util-4.11:=
+ >=xfce-base/xfce4-panel-4.11:=
+ >=xfce-base/xfconf-4.10:="
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_setup() {
+ # TODO: libido3-13.10.0 needs ubuntu-private.h from Ubuntu's GTK+ 3.x
+ XFCONF=(
+ --disable-ido
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS README THANKS )
+}
+
+src_install() {
+ default
+
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}