summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Dupeyron <calchan@gentoo.org>2018-04-13 13:12:47 -0500
committerDenis Dupeyron <calchan@gentoo.org>2018-04-13 13:16:16 -0500
commit4f1b92892813861c1ec21381725873a6cdd0b647 (patch)
tree7894fea42b01a4b1d342b92eed28961d38019274 /xfce-extra/xfce4-mailwatch-plugin
parentdev-qt: 5.9.5 version bump (diff)
downloadgentoo-4f1b92892813861c1ec21381725873a6cdd0b647.tar.gz
gentoo-4f1b92892813861c1ec21381725873a6cdd0b647.tar.bz2
gentoo-4f1b92892813861c1ec21381725873a6cdd0b647.zip
xfce-extra/xfce4-mailwatch-plugin: remove obsolete xfconf.eclass, migrate to EAPI6
Package-Manager: Portage-2.3.28, Repoman-2.3.9
Diffstat (limited to 'xfce-extra/xfce4-mailwatch-plugin')
-rw-r--r--xfce-extra/xfce4-mailwatch-plugin/xfce4-mailwatch-plugin-1.2.0-r1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-mailwatch-plugin/xfce4-mailwatch-plugin-1.2.0-r1.ebuild b/xfce-extra/xfce4-mailwatch-plugin/xfce4-mailwatch-plugin-1.2.0-r1.ebuild
new file mode 100644
index 000000000000..0c70bc8952d1
--- /dev/null
+++ b/xfce-extra/xfce4-mailwatch-plugin/xfce4-mailwatch-plugin-1.2.0-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2-utils
+
+DESCRIPTION="An mail notification panel plug-in for the Xfce desktop environment"
+HOMEPAGE="http://spuriousinterrupt.org/projects/xfce4-mailwatch-plugin/"
+SRC_URI="mirror://xfce/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="ipv6 ssl"
+
+RDEPEND=">=dev-libs/glib-2:=
+ >=x11-libs/gtk+-2.18:2=
+ x11-libs/libX11:=
+ >=xfce-base/exo-0.7.2
+ >=xfce-base/libxfce4ui-4.10:=
+ >=xfce-base/libxfce4util-4.10:=
+ >=xfce-base/xfce4-panel-4.10
+ ssl? (
+ dev-libs/libgcrypt:0=
+ >=net-libs/gnutls-2:=
+ )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_configure() {
+ econf $(use_enable ssl) $(use_enable ipv6)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}