summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2016-11-05 23:18:27 +0100
committerMichał Górny <mgorny@gentoo.org>2016-11-05 23:18:54 +0100
commit7380b886efc339a72a05ad89812de4779e925341 (patch)
treec8788e44ea6980417aac0f011c697a45d3360239 /xfce-extra/xfce4-notifyd/xfce4-notifyd-0.3.3.ebuild
parentapp-office/libreoffice: Drop old (diff)
downloadgentoo-7380b886efc339a72a05ad89812de4779e925341.tar.gz
gentoo-7380b886efc339a72a05ad89812de4779e925341.tar.bz2
gentoo-7380b886efc339a72a05ad89812de4779e925341.zip
xfce-extra/xfce4-notifyd: Bump to 0.3.3
Diffstat (limited to 'xfce-extra/xfce4-notifyd/xfce4-notifyd-0.3.3.ebuild')
-rw-r--r--xfce-extra/xfce4-notifyd/xfce4-notifyd-0.3.3.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-notifyd/xfce4-notifyd-0.3.3.ebuild b/xfce-extra/xfce4-notifyd/xfce4-notifyd-0.3.3.ebuild
new file mode 100644
index 000000000000..6434b5944154
--- /dev/null
+++ b/xfce-extra/xfce4-notifyd/xfce4-notifyd-0.3.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit xfconf
+
+DESCRIPTION="Notification daemon for the Xfce desktop environment"
+HOMEPAGE="http://goodies.xfce.org/projects/applications/xfce4-notifyd"
+SRC_URI="mirror://xfce/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="debug"
+
+RDEPEND=">=dev-libs/glib-2.42:2=
+ >=x11-libs/gtk+-3.14:3=
+ >=x11-libs/libnotify-0.7:=
+ >=xfce-base/libxfce4ui-4.12:=[gtk3(+)]
+ >=xfce-base/libxfce4util-4.12:=
+ >=xfce-base/xfconf-4.10:="
+DEPEND="${RDEPEND}
+ dev-util/gdbus-codegen
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_setup() {
+ XFCONF=( $(xfconf_use_debug) )
+ DOCS=( AUTHORS NEWS README TODO )
+}