summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-01-15 07:39:35 +0100
committerMichał Górny <mgorny@gentoo.org>2020-01-15 08:20:21 +0100
commitf5ca32d4347cda34e37c64726e6d835f6ce27093 (patch)
tree1da96d2c30f9032f38d94f450e58f1732a8bac1b /xfce-extra/xfce4-panel-profiles
parentdev-util/catfish: Bump to 1.4.13 (diff)
downloadgentoo-f5ca32d4347cda34e37c64726e6d835f6ce27093.tar.gz
gentoo-f5ca32d4347cda34e37c64726e6d835f6ce27093.tar.bz2
gentoo-f5ca32d4347cda34e37c64726e6d835f6ce27093.zip
xfce-extra/xfce4-panel-profiles: Bump to 1.0.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra/xfce4-panel-profiles')
-rw-r--r--xfce-extra/xfce4-panel-profiles/Manifest1
-rw-r--r--xfce-extra/xfce4-panel-profiles/xfce4-panel-profiles-1.0.10.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-panel-profiles/Manifest b/xfce-extra/xfce4-panel-profiles/Manifest
index b565919ab248..be779108f2c4 100644
--- a/xfce-extra/xfce4-panel-profiles/Manifest
+++ b/xfce-extra/xfce4-panel-profiles/Manifest
@@ -1 +1,2 @@
+DIST xfce4-panel-profiles-1.0.10.tar.bz2 62196 BLAKE2B 205469ab841843395429605660864a4d9496dde942ca5c8a587f32bc7143c7076f362ea0f9a488f20df3ce8ee357c4b236d3077ac07497673b3214d8fa02c20e SHA512 efd59d585cc916cfc9d87961a58f05dad754a70f1971d9c49a071e20b96bb28e6bd5fa13508430e5c0f15976db7c438d2c68e0ae5936563388fbbe02fffdb50a
DIST xfce4-panel-profiles-1.0.9.tar.bz2 58886 BLAKE2B 3711bfdad68701af833e8ffcb8ada151b1120168193d8508d14dcbb3eabdd5eeb9f0b3b5ecad3c17e5e3afa1b42e73e72340b8ea2fcf9efa5235415384a49018 SHA512 a9b381d357482582210e153fdf1ced8055847ace0507dafc29fc952070fc4fe8fd34aff62342f442ec7045cfe87550c56ccf5d78c0f0a7de7ed64e4c303aab45
diff --git a/xfce-extra/xfce4-panel-profiles/xfce4-panel-profiles-1.0.10.ebuild b/xfce-extra/xfce4-panel-profiles/xfce4-panel-profiles-1.0.10.ebuild
new file mode 100644
index 000000000000..be439f96939e
--- /dev/null
+++ b/xfce-extra/xfce4-panel-profiles/xfce4-panel-profiles-1.0.10.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit python-single-r1
+
+DESCRIPTION="Simple application to manage Xfce panel layouts"
+HOMEPAGE="https://git.xfce.org/apps/xfce4-panel-profiles/about/"
+SRC_URI="https://archive.xfce.org/src/apps/xfce4-panel-profiles/$(ver_cut 1-2)/${P}.tar.bz2"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}"
+RDEPEND="${DEPEND}
+ dev-libs/gobject-introspection
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ x11-libs/gtk+:3[introspection]
+ xfce-base/xfce4-panel"
+
+src_prepare() {
+ default
+ sed -i -e '/install/s:.gz::' Makefile.in.in || die
+}
+
+src_configure() {
+ # home-made configure script, yay!
+ ./configure --prefix="${EPREFIX}/usr" --python="${EPYTHON}" || die
+}
+
+src_install() {
+ default
+
+ # the default gets it right
+ rm -r "${ED}"/usr/share/doc/xfce4-panel-profiles || die
+}