summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-23 09:31:20 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-23 09:38:59 +0100
commitaa3490337b817dc89150796df6d5f982a85adbf9 (patch)
tree22b1d117162ed0489ba59e32c5ad07eb68ebe97f /xfce-extra/xfce4-screenshooter/xfce4-screenshooter-1.9.8.ebuild
parentprofiles/package.mask: drop masks for removed packages (diff)
downloadgentoo-aa3490337b817dc89150796df6d5f982a85adbf9.tar.gz
gentoo-aa3490337b817dc89150796df6d5f982a85adbf9.tar.bz2
gentoo-aa3490337b817dc89150796df6d5f982a85adbf9.zip
xfce-extra/xfce4-screenshooter: Bump to 1.9.8
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra/xfce4-screenshooter/xfce4-screenshooter-1.9.8.ebuild')
-rw-r--r--xfce-extra/xfce4-screenshooter/xfce4-screenshooter-1.9.8.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-screenshooter/xfce4-screenshooter-1.9.8.ebuild b/xfce-extra/xfce4-screenshooter/xfce4-screenshooter-1.9.8.ebuild
new file mode 100644
index 000000000000..cbeaf43cca12
--- /dev/null
+++ b/xfce-extra/xfce4-screenshooter/xfce4-screenshooter-1.9.8.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils
+
+DESCRIPTION="Xfce4 screenshooter application and panel plugin"
+HOMEPAGE="https://goodies.xfce.org/projects/applications/xfce4-screenshooter"
+SRC_URI="https://archive.xfce.org/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.16:=
+ >=net-libs/libsoup-2.26:=
+ >=x11-libs/gdk-pixbuf-2.16:=
+ >=x11-libs/gtk+-3.20:3=
+ dev-libs/libxml2:=
+ x11-libs/libX11:=
+ x11-libs/libXext:=
+ x11-libs/libXfixes:=
+ >=xfce-base/exo-0.11:=
+ >=xfce-base/xfce4-panel-4.12:=
+ >=xfce-base/libxfce4util-4.10:=
+ >=xfce-base/libxfce4ui-4.12:="
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ dev-util/intltool
+ sys-apps/help2man
+ virtual/pkgconfig"
+
+src_configure() {
+ local myconf=(
+ --enable-xfixes
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}