summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-21 00:46:35 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-21 00:52:24 +0100
commit6e3f10aee62e58c23c881b5664fe9b2865031562 (patch)
treee11388cf825f14e627e0e82716f3abda55a229f2 /xfce-extra/xfce4-systemload-plugin/xfce4-systemload-plugin-1.2.4.ebuild
parentnet-misc/httpie: bump to v2.3.0 (diff)
downloadgentoo-6e3f10aee62e58c23c881b5664fe9b2865031562.tar.gz
gentoo-6e3f10aee62e58c23c881b5664fe9b2865031562.tar.bz2
gentoo-6e3f10aee62e58c23c881b5664fe9b2865031562.zip
xfce-extra/xfce4-systemload-plugin: Bump to 1.2.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra/xfce4-systemload-plugin/xfce4-systemload-plugin-1.2.4.ebuild')
-rw-r--r--xfce-extra/xfce4-systemload-plugin/xfce4-systemload-plugin-1.2.4.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-systemload-plugin/xfce4-systemload-plugin-1.2.4.ebuild b/xfce-extra/xfce4-systemload-plugin/xfce4-systemload-plugin-1.2.4.ebuild
new file mode 100644
index 000000000000..d84941a73ff4
--- /dev/null
+++ b/xfce-extra/xfce4-systemload-plugin/xfce4-systemload-plugin-1.2.4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="System load plug-in for Xfce panel"
+HOMEPAGE="https://goodies.xfce.org/projects/panel-plugins/xfce4-systemload-plugin"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="upower"
+
+RDEPEND=">=xfce-base/libxfce4ui-4.12:=[gtk3(+)]
+ >=xfce-base/xfce4-panel-4.12:=
+ upower? ( >=sys-power/upower-0.9.23 )"
+DEPEND=${RDEPEND}
+BDEPEND="
+ dev-util/intltool
+ virtual/pkgconfig"
+
+src_configure() {
+ econf $(use_enable upower)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}