summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-12-28 09:39:27 +0100
committerMichał Górny <mgorny@gentoo.org>2020-12-28 09:42:20 +0100
commit24eab02ae88a997989c540f57cc675e3cfba836a (patch)
treed2d5d9b217c2639fd5a5bc263b86ef8db6a55c7e /xfce-extra/xfce4-verve-plugin/xfce4-verve-plugin-2.0.1.ebuild
parentdev-python/importlib_resources: Bump to 4.1.1 (diff)
downloadgentoo-24eab02ae88a997989c540f57cc675e3cfba836a.tar.gz
gentoo-24eab02ae88a997989c540f57cc675e3cfba836a.tar.bz2
gentoo-24eab02ae88a997989c540f57cc675e3cfba836a.zip
xfce-extra/xfce4-verve-plugin: Bump to 2.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra/xfce4-verve-plugin/xfce4-verve-plugin-2.0.1.ebuild')
-rw-r--r--xfce-extra/xfce4-verve-plugin/xfce4-verve-plugin-2.0.1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-verve-plugin/xfce4-verve-plugin-2.0.1.ebuild b/xfce-extra/xfce4-verve-plugin/xfce4-verve-plugin-2.0.1.ebuild
new file mode 100644
index 000000000000..89349ae153f8
--- /dev/null
+++ b/xfce-extra/xfce4-verve-plugin/xfce4-verve-plugin-2.0.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A comfortable command line plugin for the Xfce panel"
+HOMEPAGE="https://goodies.xfce.org/projects/panel-plugins/xfce4-verve-plugin"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND=">=xfce-base/libxfce4ui-4.12:=
+ >=xfce-base/xfce4-panel-4.12:=
+ dev-libs/glib:2=
+ >=dev-libs/libpcre-5:="
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/intltool
+ virtual/pkgconfig"
+
+src_configure() {
+ local myconf=(
+ --libexecdir="${EPREFIX}"/usr/$(get_libdir)
+ )
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}