summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2016-11-20 23:56:56 +0800
committerJason Zaman <perfinion@gentoo.org>2016-11-21 00:19:01 +0800
commitbe248f1c27e8b881daa9ad3afb6efb38ae59a189 (patch)
tree2c763aa938598a1d883045283135f4d18c7db9f2 /xfce-extra/xfce4-wavelan-plugin/xfce4-wavelan-plugin-0.6.0.ebuild
parentxfce-extra/xfce4-systemload-plugin: bump version and EAPI6 (diff)
downloadgentoo-be248f1c27e8b881daa9ad3afb6efb38ae59a189.tar.gz
gentoo-be248f1c27e8b881daa9ad3afb6efb38ae59a189.tar.bz2
gentoo-be248f1c27e8b881daa9ad3afb6efb38ae59a189.zip
xfce-extra/xfce4-wavelan-plugin: bump version and EAPI6
Package-Manager: portage-2.3.0
Diffstat (limited to 'xfce-extra/xfce4-wavelan-plugin/xfce4-wavelan-plugin-0.6.0.ebuild')
-rw-r--r--xfce-extra/xfce4-wavelan-plugin/xfce4-wavelan-plugin-0.6.0.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-wavelan-plugin/xfce4-wavelan-plugin-0.6.0.ebuild b/xfce-extra/xfce4-wavelan-plugin/xfce4-wavelan-plugin-0.6.0.ebuild
new file mode 100644
index 000000000000..fc52736a74d9
--- /dev/null
+++ b/xfce-extra/xfce4-wavelan-plugin/xfce4-wavelan-plugin-0.6.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit fdo-mime gnome2-utils
+
+DESCRIPTION="A panel plug-in to display wireless interface statistics"
+HOMEPAGE="http://goodies.xfce.org/projects/panel-plugins/xfce4-wavelan-plugin"
+SRC_URI="mirror://xfce/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
+IUSE="kernel_linux"
+
+COMMON_DEPEND=">=xfce-base/libxfce4ui-4.12:=[gtk3(+)]
+ >=xfce-base/xfce4-panel-4.12:="
+RDEPEND="${COMMON_DEPEND}
+ kernel_linux? ( sys-apps/net-tools )"
+DEPEND="${COMMON_DEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog NEWS README THANKS )
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+ fdo-mime_mime_database_update
+ gnome2_icon_cache_update
+}