summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-10-12 09:08:46 +0200
committerMichał Górny <mgorny@gentoo.org>2017-10-12 09:32:50 +0200
commit530c1d865dff64f5f0e2c7db557c4768e1421124 (patch)
tree44c7f831202ad3f11c49af9f9b60217de5428d40 /xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.8.10.ebuild
parentapp-admin/keepassxc: Fixed HOMEPAGE (bug #620968). (diff)
downloadgentoo-530c1d865dff64f5f0e2c7db557c4768e1421124.tar.gz
gentoo-530c1d865dff64f5f0e2c7db557c4768e1421124.tar.bz2
gentoo-530c1d865dff64f5f0e2c7db557c4768e1421124.zip
xfce-extra/xfce4-weather-plugin: Bump to 0.8.10
Diffstat (limited to 'xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.8.10.ebuild')
-rw-r--r--xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.8.10.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.8.10.ebuild b/xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.8.10.ebuild
new file mode 100644
index 000000000000..97a0bc7666ea
--- /dev/null
+++ b/xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.8.10.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2-utils
+
+DESCRIPTION="A weather plug-in for the Xfce desktop environment"
+HOMEPAGE="https://goodies.xfce.org/projects/panel-plugins/xfce4-weather-plugin"
+SRC_URI="mirror://xfce/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="upower"
+
+RDEPEND=">=dev-libs/glib-2.20:=
+ dev-libs/libxml2:=
+ >=net-libs/libsoup-2.32:=
+ >=x11-libs/gtk+-2.14:2=
+ >=xfce-base/libxfce4ui-4.10:=
+ >=xfce-base/libxfce4util-4.10:=
+ >=xfce-base/xfce4-panel-4.10:=
+ upower? ( || ( >=sys-power/upower-0.9.23 sys-power/upower-pm-utils ) )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig"
+
+DOCS=( AUTHORS ChangeLog NEWS README TODO )
+
+src_configure() {
+ # For GEONAMES_USERNAME, read README file and ask ssuominen@!
+ local myconf=(
+ $(use_enable upower)
+ GEONAMES_USERNAME=Gentoo
+ )
+ econf "${myconf[@]}"
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}