summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-03-23 15:23:28 +0100
committerMichał Górny <mgorny@gentoo.org>2019-03-23 15:23:28 +0100
commit910d57bd67e5d87806ccad0bb48953e8e7b6b8f3 (patch)
tree4fd2459d8111f67fe8c775044fc9a4ca40af217b /xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.9.1.ebuild
parentdev-libs/libclc: Bump to 0.2.0_pre20190313 snapshot (diff)
downloadgentoo-910d57bd67e5d87806ccad0bb48953e8e7b6b8f3.tar.gz
gentoo-910d57bd67e5d87806ccad0bb48953e8e7b6b8f3.tar.bz2
gentoo-910d57bd67e5d87806ccad0bb48953e8e7b6b8f3.zip
xfce-extra/xfce4-weather-plugin: Bump to 0.9.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.9.1.ebuild')
-rw-r--r--xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.9.1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.9.1.ebuild b/xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.9.1.ebuild
new file mode 100644
index 000000000000..a2e80c713089
--- /dev/null
+++ b/xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.9.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2-utils
+
+DESCRIPTION="A weather plug-in for the Xfce desktop environment"
+HOMEPAGE="https://goodies.xfce.org/projects/panel-plugins/xfce4-weather-plugin"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="upower"
+
+RDEPEND=">=dev-libs/glib-2.42
+ dev-libs/libxml2:=
+ >=net-libs/libsoup-2.42:=[ssl]
+ >=x11-libs/gtk+-3.22:3
+ >=xfce-base/libxfce4ui-4.12:=
+ >=xfce-base/libxfce4util-4.12:=
+ >=xfce-base/xfce4-panel-4.12:=
+ upower? ( >=sys-power/upower-0.9.23 )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig"
+
+src_configure() {
+ # For GEONAMES_USERNAME, read README file and ask ssuominen@!
+ local myconf=(
+ $(use_enable upower)
+ GEONAMES_USERNAME=Gentoo
+ )
+ econf "${myconf[@]}"
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}