summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-02-25 22:05:42 +0100
committerMichał Górny <mgorny@gentoo.org>2020-02-25 22:07:09 +0100
commit0eb3c953fd7916e2c13f70a41901cee3a5d47025 (patch)
tree749046c0c4952412e48ab2221873317802a74422 /xfce-extra/xfce4-weather-plugin
parentsys-cluster/kube-scheduler: typo fix (diff)
downloadgentoo-0eb3c953fd7916e2c13f70a41901cee3a5d47025.tar.gz
gentoo-0eb3c953fd7916e2c13f70a41901cee3a5d47025.tar.bz2
gentoo-0eb3c953fd7916e2c13f70a41901cee3a5d47025.zip
xfce-extra/xfce4-weather-plugin: Bump to 0.10.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra/xfce4-weather-plugin')
-rw-r--r--xfce-extra/xfce4-weather-plugin/Manifest1
-rw-r--r--xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.10.1.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-weather-plugin/Manifest b/xfce-extra/xfce4-weather-plugin/Manifest
index ed64d625b625..78c8b41a4109 100644
--- a/xfce-extra/xfce4-weather-plugin/Manifest
+++ b/xfce-extra/xfce4-weather-plugin/Manifest
@@ -1 +1,2 @@
DIST xfce4-weather-plugin-0.10.0.tar.bz2 3032575 BLAKE2B 2dc81c8d60ab63ff9adb90d53a5eb89e98c3e4b950d8b5943fb2b39b4944164470d7e10dcd096ef90665129d1aa59e052b3140d1462077a285afde4bcdcba047 SHA512 168a850c60f419f40f6c05dbedf24a4f3aea3be04e14c5eb2596a03a8dee5850a80d06b63bee54690b63385109d53ccf8ff2b97a2c879e196046308436a7d126
+DIST xfce4-weather-plugin-0.10.1.tar.bz2 3026945 BLAKE2B 511427d430b696983855687db12ef8877eabc6a0e2518f511e9f90286b08fcf8b52da10bf6ba7b435c069d5018b653c2c7703e8b9ec3f858251ad9c949acb760 SHA512 14fd17da60b0ac76dd0f8e1b7858e8cef57c5168b7467412e1d45ae91e44858c7619cdca2ee59e242d2888038d458faa7580bf02d1cad3371ec80acc9012f569
diff --git a/xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.10.1.ebuild b/xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.10.1.ebuild
new file mode 100644
index 000000000000..cf19f7d52b16
--- /dev/null
+++ b/xfce-extra/xfce4-weather-plugin/xfce4-weather-plugin-0.10.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils
+
+DESCRIPTION="A weather plug-in for the Xfce desktop environment"
+HOMEPAGE="https://goodies.xfce.org/projects/panel-plugins/xfce4-weather-plugin"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86"
+IUSE="upower"
+
+RDEPEND=">=dev-libs/glib-2.42
+ dev-libs/libxml2
+ >=net-libs/libsoup-2.42[ssl]
+ >=x11-libs/gtk+-3.22:3
+ >=xfce-base/libxfce4ui-4.14:=
+ >=xfce-base/libxfce4util-4.14:=
+ >=xfce-base/xfce4-panel-4.14:=
+ upower? ( >=sys-power/upower-0.9.23 )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig"
+
+src_configure() {
+ # For GEONAMES_USERNAME, read README file and ask ssuominen@!
+ local myconf=(
+ $(use_enable upower)
+ GEONAMES_USERNAME=Gentoo
+ )
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}