summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-10-01 20:26:33 +0200
committerMichał Górny <mgorny@gentoo.org>2018-10-01 20:43:28 +0200
commit6c47e6ae4ef75bfe7c4333afb4e214f7dbe1178c (patch)
treefcb0c5ddd95dc12e93edb64f8f5abd09882878c5 /xfce-extra/xfce4-whiskermenu-plugin/xfce4-whiskermenu-plugin-2.3.0.ebuild
parentxfce-extra/xfce4-whiskermenu-plugin: Clean old up (diff)
downloadgentoo-6c47e6ae4ef75bfe7c4333afb4e214f7dbe1178c.tar.gz
gentoo-6c47e6ae4ef75bfe7c4333afb4e214f7dbe1178c.tar.bz2
gentoo-6c47e6ae4ef75bfe7c4333afb4e214f7dbe1178c.zip
xfce-extra/xfce4-whiskermenu-plugin: Bump to 2.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra/xfce4-whiskermenu-plugin/xfce4-whiskermenu-plugin-2.3.0.ebuild')
-rw-r--r--xfce-extra/xfce4-whiskermenu-plugin/xfce4-whiskermenu-plugin-2.3.0.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-whiskermenu-plugin/xfce4-whiskermenu-plugin-2.3.0.ebuild b/xfce-extra/xfce4-whiskermenu-plugin/xfce4-whiskermenu-plugin-2.3.0.ebuild
new file mode 100644
index 000000000000..0a191020f9aa
--- /dev/null
+++ b/xfce-extra/xfce4-whiskermenu-plugin/xfce4-whiskermenu-plugin-2.3.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils gnome2-utils
+
+DESCRIPTION="Alternate application launcher for Xfce"
+HOMEPAGE="https://gottcode.org/xfce4-whiskermenu-plugin"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+RDEPEND="
+ virtual/libintl:=
+ x11-libs/gtk+:3=
+ >=xfce-base/exo-0.11.0:=
+ xfce-base/garcon:=
+ xfce-base/libxfce4ui:=
+ xfce-base/libxfce4util:=
+ xfce-base/xfce4-panel:="
+
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_AS_NEEDED=OFF
+ -DENABLE_LINKER_OPTIMIZED_HASH_TABLES=OFF
+ -DENABLE_DEVELOPER_MODE=OFF
+ )
+
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}