summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-01-20 10:45:42 +0100
committerMichał Górny <mgorny@gentoo.org>2019-01-20 11:41:50 +0100
commit82f7ff07c978c88fcaca76b2878dd8098bc9488a (patch)
tree829f86471cd52913bd5dd2d8100c26c6a4454c56 /xfce-extra/xfce4-whiskermenu-plugin/xfce4-whiskermenu-plugin-2.3.1.ebuild
parentdev-python/pygit2: Bump to 0.27.4 (diff)
downloadgentoo-82f7ff07c978c88fcaca76b2878dd8098bc9488a.tar.gz
gentoo-82f7ff07c978c88fcaca76b2878dd8098bc9488a.tar.bz2
gentoo-82f7ff07c978c88fcaca76b2878dd8098bc9488a.zip
xfce-extra/xfce4-whiskermenu-plugin: Bump to 2.3.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra/xfce4-whiskermenu-plugin/xfce4-whiskermenu-plugin-2.3.1.ebuild')
-rw-r--r--xfce-extra/xfce4-whiskermenu-plugin/xfce4-whiskermenu-plugin-2.3.1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-whiskermenu-plugin/xfce4-whiskermenu-plugin-2.3.1.ebuild b/xfce-extra/xfce4-whiskermenu-plugin/xfce4-whiskermenu-plugin-2.3.1.ebuild
new file mode 100644
index 000000000000..8f071eb58f89
--- /dev/null
+++ b/xfce-extra/xfce4-whiskermenu-plugin/xfce4-whiskermenu-plugin-2.3.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils gnome2-utils
+
+DESCRIPTION="Alternate application launcher for Xfce"
+HOMEPAGE="https://gottcode.org/xfce4-whiskermenu-plugin"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+RDEPEND="
+ virtual/libintl:=
+ x11-libs/gtk+:3=
+ >=xfce-base/exo-0.11.0:=
+ xfce-base/garcon:=
+ xfce-base/libxfce4ui:=
+ xfce-base/libxfce4util:=
+ xfce-base/xfce4-panel:="
+
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_AS_NEEDED=OFF
+ -DENABLE_LINKER_OPTIMIZED_HASH_TABLES=OFF
+ -DENABLE_DEVELOPER_MODE=OFF
+ )
+
+ cmake-utils_src_configure
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}