summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-04-09 17:54:05 +0200
committerMichał Górny <mgorny@gentoo.org>2019-04-09 18:09:03 +0200
commit8876eeb70be3d9479417f91c7d478c182c9b0a09 (patch)
treefef7e37434f97fe7da0518fe18cbed9d5429a765 /xfce-extra/xfdashboard/xfdashboard-0.6.1.ebuild
parentxfce-extra/xfce4-windowck-plugin: Bump to 0.4.5 (diff)
downloadgentoo-8876eeb70be3d9479417f91c7d478c182c9b0a09.tar.gz
gentoo-8876eeb70be3d9479417f91c7d478c182c9b0a09.tar.bz2
gentoo-8876eeb70be3d9479417f91c7d478c182c9b0a09.zip
xfce-extra/xfdashboard: Bump to 0.6.1 (stable branch)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra/xfdashboard/xfdashboard-0.6.1.ebuild')
-rw-r--r--xfce-extra/xfdashboard/xfdashboard-0.6.1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/xfce-extra/xfdashboard/xfdashboard-0.6.1.ebuild b/xfce-extra/xfdashboard/xfdashboard-0.6.1.ebuild
new file mode 100644
index 000000000000..853578156a6f
--- /dev/null
+++ b/xfce-extra/xfdashboard/xfdashboard-0.6.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils
+
+DESCRIPTION="Maybe a GNOME shell like dashboard for the Xfce desktop environment"
+HOMEPAGE="https://goodies.xfce.org/projects/applications/xfdashboard/start"
+SRC_URI="https://archive.xfce.org/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/dbus-glib-0.100:=
+ >=dev-libs/glib-2.32:2
+ >=x11-libs/gtk+-3.2:3
+ >=media-libs/clutter-1.12:1.0=
+ >=x11-libs/libwnck-3:3=
+ x11-libs/libX11:=
+ x11-libs/libXcomposite:=
+ x11-libs/libXdamage:=
+ x11-libs/libXinerama:=
+ >=xfce-base/garcon-0.2.0:=
+ >=xfce-base/libxfce4ui-4.10:=
+ >=xfce-base/libxfce4util-4.10:=
+ >=xfce-base/xfconf-4.10:="
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig"
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}