summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-03-31 09:58:16 +0200
committerMichał Górny <mgorny@gentoo.org>2018-03-31 10:03:34 +0200
commit1fff3075d4cde085116dd44812817a01e8714268 (patch)
tree3a659c4c4713e18368c103d2728b155cf9b2fccc /xfce-extra
parentdev-python/pygit2: Bump to 0.27.0 (diff)
downloadgentoo-1fff3075d4cde085116dd44812817a01e8714268.tar.gz
gentoo-1fff3075d4cde085116dd44812817a01e8714268.tar.bz2
gentoo-1fff3075d4cde085116dd44812817a01e8714268.zip
xfce-extra/tumbler: Bump to 0.2.1
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/tumbler/Manifest1
-rw-r--r--xfce-extra/tumbler/tumbler-0.2.1.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/xfce-extra/tumbler/Manifest b/xfce-extra/tumbler/Manifest
index 9e4799dc9a33..1f5c66ca577f 100644
--- a/xfce-extra/tumbler/Manifest
+++ b/xfce-extra/tumbler/Manifest
@@ -1 +1,2 @@
DIST tumbler-0.2.0.tar.bz2 571300 BLAKE2B b4b923716897773febaff21c7d13fb8e4abfb36f9a0a02e4b777516ecd6170552d757057a228832924f4d8cb9f61380109ef52d0efaddcf69069ca5c0df4ae6c SHA512 54f83f904b32fcde5960f3343f8f4477bd30cd96a784aec5a3cb70aa2c9f924e833b2c0b429d608a36c75104d2689975d688358893127aed501f3cd8f24c280b
+DIST tumbler-0.2.1.tar.bz2 577996 BLAKE2B fc1b9dbf9fee4453f6de5d4e901fac13e38534560230cb18e51c3325f648d51885081c5af182af2621f682cc22b0abb99a02ef45ef37a7e604249baa73eaacfc SHA512 c88595312e34534cb43d304d97a60886338d92997a7d0b5a8bb22d06dfb13d7a7445b148ba4af3766df24f6c87106a7f65758debf198e46d9fabf00049b13386
diff --git a/xfce-extra/tumbler/tumbler-0.2.1.ebuild b/xfce-extra/tumbler/tumbler-0.2.1.ebuild
new file mode 100644
index 000000000000..c4289a84e246
--- /dev/null
+++ b/xfce-extra/tumbler/tumbler-0.2.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="A thumbnail service for Thunar"
+HOMEPAGE="https://docs.xfce.org/xfce/thunar/start"
+SRC_URI="mirror://xfce/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="curl ffmpeg gstreamer jpeg odf pdf raw"
+
+COMMON_DEPEND=">=dev-libs/glib-2.26:2=
+ media-libs/freetype:2=
+ media-libs/libpng:0=
+ >=sys-apps/dbus-1.6:=
+ >=x11-libs/gdk-pixbuf-2.14:2=
+ curl? ( >=net-misc/curl-7.25:= )
+ ffmpeg? ( >=media-video/ffmpegthumbnailer-2.0.8:= )
+ gstreamer? (
+ media-libs/gstreamer:1.0
+ media-libs/gst-plugins-base:1.0
+ )
+ jpeg? ( virtual/jpeg:0= )
+ odf? ( >=gnome-extra/libgsf-1.14.20:= )
+ pdf? ( >=app-text/poppler-0.12.4[cairo] )
+ raw? ( >=media-libs/libopenraw-0.0.8:=[gtk] )"
+RDEPEND="${COMMON_DEPEND}
+ >=xfce-base/thunar-1.4
+ gstreamer? ( media-plugins/gst-plugins-meta:1.0 )"
+DEPEND="${COMMON_DEPEND}
+ dev-util/gtk-doc-am
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_configure() {
+ local myconf=(
+ $(use_enable curl cover-thumbnailer)
+ $(use_enable jpeg jpeg-thumbnailer)
+ $(use_enable ffmpeg ffmpeg-thumbnailer)
+ $(use_enable gstreamer gstreamer-thumbnailer)
+ $(use_enable odf odf-thumbnailer)
+ $(use_enable pdf poppler-thumbnailer)
+ $(use_enable raw raw-thumbnailer)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+
+ find "${D}" -name '*.la' -delete || die
+}