summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-04-12 20:32:34 +0200
committerMichał Górny <mgorny@gentoo.org>2018-04-12 21:12:45 +0200
commit33c92cfe52fb88eb75b84dcb8a79e0990196070f (patch)
treed07a392dc66c279ed3c8a6390cc67524b75996ca /xfce-extra
parentmedia-video/parole: Bump to 1.0.1 (translation update) (diff)
downloadgentoo-33c92cfe52fb88eb75b84dcb8a79e0990196070f.tar.gz
gentoo-33c92cfe52fb88eb75b84dcb8a79e0990196070f.tar.bz2
gentoo-33c92cfe52fb88eb75b84dcb8a79e0990196070f.zip
xfce-extra/xfce4-pulseaudio-plugin: Bump to 0.4.1 (translations upd)
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfce4-pulseaudio-plugin/Manifest1
-rw-r--r--xfce-extra/xfce4-pulseaudio-plugin/xfce4-pulseaudio-plugin-0.4.1.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-pulseaudio-plugin/Manifest b/xfce-extra/xfce4-pulseaudio-plugin/Manifest
index 18b4a030e4a8..4f14dc4f1371 100644
--- a/xfce-extra/xfce4-pulseaudio-plugin/Manifest
+++ b/xfce-extra/xfce4-pulseaudio-plugin/Manifest
@@ -1,2 +1,3 @@
DIST xfce4-pulseaudio-plugin-0.3.4.tar.bz2 400380 BLAKE2B b8cd4df84f3119d90a7671d8217eaeb83025206d9bfdc5aaae2281cd7c9b13ab03fa8a99ff1eb352f2fa01e889bcd3a505b558ce9884c46b1136bc75a6fb22e7 SHA512 2dfa6a4567caeb2f336b1d9e32cedb5f03e363253549810e768bb51746cd1db362ebd0990098e461a71b8206d81ff877291860a3568a288fe2010498ad486c78
DIST xfce4-pulseaudio-plugin-0.4.0.tar.bz2 391068 BLAKE2B c06b05fbb910e7a1d13fde976f6b8b3f0d22de43223bdc8472440c52868cf1f3f37359a81c96efb2644ba202382cb53c2780214d3fe1af7977ec2e9d2f5e8c19 SHA512 28e2185ffea3f6e3e7d07e0cdd5062d423dddb2f7ee4a1e2f2965d4bf65e11cd0a409403ffb7d6afd89206dc37cf5700430ad6a53967395e3a58dde6dd13503f
+DIST xfce4-pulseaudio-plugin-0.4.1.tar.bz2 391791 BLAKE2B 038eedbecbc6ba4845f1be86938aa57165f55e1d287f914deea998383fad5a019d1ca7500c7366d76692c1b59cf87214e2057833786318cb69c326eea2a69ea4 SHA512 e7b778c78ede9ad62afaa379941ce03636a79dd000e40e748079d3e0f3c71f2e68e32cf85e527be4e1192074652714db4b7c5707b727066198c2ea43184a71cc
diff --git a/xfce-extra/xfce4-pulseaudio-plugin/xfce4-pulseaudio-plugin-0.4.1.ebuild b/xfce-extra/xfce4-pulseaudio-plugin/xfce4-pulseaudio-plugin-0.4.1.ebuild
new file mode 100644
index 000000000000..4dcbd980caaf
--- /dev/null
+++ b/xfce-extra/xfce4-pulseaudio-plugin/xfce4-pulseaudio-plugin-0.4.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2-utils
+
+DESCRIPTION="A panel plug-in for PulseAudio volume control"
+HOMEPAGE="https://git.xfce.org/panel-plugins/xfce4-pulseaudio-plugin/"
+SRC_URI="mirror://xfce/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="debug keybinder libnotify wnck"
+
+RDEPEND=">=dev-libs/glib-2.42.0:=
+ media-sound/pulseaudio:=
+ >=x11-libs/gtk+-3.20.0:3=
+ >=xfce-base/libxfce4ui-4.11.0:=[gtk3(+)]
+ >=xfce-base/libxfce4util-4.9.0:=
+ >=xfce-base/xfce4-panel-4.11.0:=
+ >=xfce-base/xfconf-4.6.0:=
+ keybinder? ( dev-libs/keybinder:3= )
+ libnotify? ( x11-libs/libnotify:= )
+ wnck? ( x11-libs/libwnck:3= )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig"
+
+src_configure() {
+ local myconf=(
+ $(use_enable keybinder)
+ $(use_enable libnotify)
+ $(use_enable wnck)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+
+ if ! has_version media-sound/pavucontrol; then
+ elog "For the 'audio mixer...' shortcut to work, you need to install"
+ elog "an external mixer application. Please either install:"
+ elog
+ elog " media-sound/pavucontrol"
+ elog
+ elog "or specify another application to use in the 'Properties' dialog."
+ fi
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}