summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-10-15 20:02:03 +0200
committerMichał Górny <mgorny@gentoo.org>2020-10-15 20:02:03 +0200
commit4d51423fbfb15edd760b556c69a8a73093804572 (patch)
tree05b5f68196330f2089d60bad649b6630ee1bb197 /xfce-extra
parentdev-libs/libevdev: Increase test timeout (diff)
downloadgentoo-4d51423fbfb15edd760b556c69a8a73093804572.tar.gz
gentoo-4d51423fbfb15edd760b556c69a8a73093804572.tar.bz2
gentoo-4d51423fbfb15edd760b556c69a8a73093804572.zip
xfce-extra/xfce4-dict: Bump to 0.8.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfce4-dict/Manifest1
-rw-r--r--xfce-extra/xfce4-dict/xfce4-dict-0.8.4.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-dict/Manifest b/xfce-extra/xfce4-dict/Manifest
index 4eeaf2fba8bd..4a8eb05287fd 100644
--- a/xfce-extra/xfce4-dict/Manifest
+++ b/xfce-extra/xfce4-dict/Manifest
@@ -1 +1,2 @@
DIST xfce4-dict-0.8.3.tar.bz2 491964 BLAKE2B 8435ea8d176301b73e34e7cb7fc2383b07e5fb5b0e9ff31c825cb51211358642771c1526971924c8e4a59c046b7133b6f82d86cfa739e68cfb89dffd13a2a65e SHA512 d4779a928e351c06d8866d1eefcf2efb5f364b64591a76abd19b87ac08905196b436725db3660e694b7071a534ebd9b08f298945a515fcaf335b74ce15eb0617
+DIST xfce4-dict-0.8.4.tar.bz2 526227 BLAKE2B da8ade9ad62dfa086c1550868d28883c1a87e90839d164f52abe92189c62981b0e3b33fc428b805d608871e1c5afb0ec9df94d5239eeeed15e16372b2592e1df SHA512 f662b94671f2179cc93010e9ff6ad7f3425cfafeb8d7c635fefb8e816d78273f0135d6c7ff3ed143e5e01985eb4275ac89827d197ed059fbfa79df69b327f253
diff --git a/xfce-extra/xfce4-dict/xfce4-dict-0.8.4.ebuild b/xfce-extra/xfce4-dict/xfce4-dict-0.8.4.ebuild
new file mode 100644
index 000000000000..28ad3e4c2e49
--- /dev/null
+++ b/xfce-extra/xfce4-dict/xfce4-dict-0.8.4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit xdg-utils
+
+DESCRIPTION="A dict.org querying application and panel plug-in for the Xfce desktop"
+HOMEPAGE="https://goodies.xfce.org/projects/applications/xfce4-dict"
+SRC_URI="https://archive.xfce.org/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.24
+ >=x11-libs/gtk+-3.22:3
+ x11-libs/libX11
+ >=xfce-base/libxfce4util-4.10:=
+ >=xfce-base/libxfce4ui-4.12:=
+ >=xfce-base/xfce4-panel-4.10:="
+DEPEND="${RDEPEND}
+ dev-util/gdbus-codegen
+ dev-util/intltool
+ virtual/pkgconfig"
+
+src_configure() {
+ econf --libexecdir="${EPREFIX}"/usr/$(get_libdir)
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}