summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-20 11:04:04 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-20 11:04:21 +0200
commit50cbb03bf8890351fedf1d6f66e6fe93bae8024b (patch)
tree0152eb91715d8eab1565a7d51dd6a7ec032c9e80 /xfce-extra
parentdev-python/python-lsp-server: fix the tests (again) (diff)
downloadgentoo-50cbb03bf8890351fedf1d6f66e6fe93bae8024b.tar.gz
gentoo-50cbb03bf8890351fedf1d6f66e6fe93bae8024b.tar.bz2
gentoo-50cbb03bf8890351fedf1d6f66e6fe93bae8024b.zip
xfce-extra/xfce4-screenshooter: Bump to 1.9.9
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfce4-screenshooter/Manifest1
-rw-r--r--xfce-extra/xfce4-screenshooter/xfce4-screenshooter-1.9.9.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-screenshooter/Manifest b/xfce-extra/xfce4-screenshooter/Manifest
index ae3d9a428ce0..68c09c828e86 100644
--- a/xfce-extra/xfce4-screenshooter/Manifest
+++ b/xfce-extra/xfce4-screenshooter/Manifest
@@ -1 +1,2 @@
DIST xfce4-screenshooter-1.9.8.tar.bz2 562481 BLAKE2B b0e644cdbc7a9a237eec1aec39b9a3b2ebc67f8241f4ff5f828174011eb8bb37a231e9c9f91ccbab7031f0ed1ccd73c506743816201dd3f21330ffe69dcd43db SHA512 325697cf37075c313956621707ec9ae40a51ec85dfa65d73ccb8695a0b2d14cff0d62a9a30114b60b0404bd9ba25728bc4c350d3c2a65def6afa4a382883746a
+DIST xfce4-screenshooter-1.9.9.tar.bz2 570962 BLAKE2B 4965c08a8c960b85fb151c7ad8d7f87cf72fdbd2c158191dc19a5ee6afefb837699961a3dee41d0270d5191fa81381cd17af06ee73d7bc17e3a72a6dc895f9ed SHA512 e157abfe6c82d6f05f1caa62e02b933474c825e6e4d613a299def58921d19fb7fb06a30aa878a51d3bf4ea83d9b18ea8c996a9b1b6c4e09f4bedc44a6a9df2e2
diff --git a/xfce-extra/xfce4-screenshooter/xfce4-screenshooter-1.9.9.ebuild b/xfce-extra/xfce4-screenshooter/xfce4-screenshooter-1.9.9.ebuild
new file mode 100644
index 000000000000..e1c7985e2bce
--- /dev/null
+++ b/xfce-extra/xfce4-screenshooter/xfce4-screenshooter-1.9.9.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils
+
+DESCRIPTION="Xfce4 screenshooter application and panel plugin"
+HOMEPAGE="https://goodies.xfce.org/projects/applications/xfce4-screenshooter"
+SRC_URI="https://archive.xfce.org/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.16:=
+ >=net-libs/libsoup-2.26:=
+ >=x11-libs/gdk-pixbuf-2.16:=
+ >=x11-libs/gtk+-3.20:3=
+ >=x11-libs/pango-1.44:=
+ dev-libs/libxml2:=
+ x11-libs/libX11:=
+ x11-libs/libXext:=
+ x11-libs/libXfixes:=
+ >=xfce-base/exo-0.11:=
+ >=xfce-base/xfce4-panel-4.12:=
+ >=xfce-base/libxfce4util-4.10:=
+ >=xfce-base/libxfce4ui-4.12:="
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ dev-util/intltool
+ sys-apps/help2man
+ virtual/pkgconfig"
+
+src_configure() {
+ local myconf=(
+ --enable-xfixes
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}