summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-06 10:46:19 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-06 10:49:55 +0200
commit5c182456307c63be9b383cfdd2b2b9979a20a91b (patch)
tree9f6d728c1d7950399f615639c587bd3210280352 /xfce-extra
parentdev-python/attrs: Bump to 21.1.0 (diff)
downloadgentoo-5c182456307c63be9b383cfdd2b2b9979a20a91b.tar.gz
gentoo-5c182456307c63be9b383cfdd2b2b9979a20a91b.tar.bz2
gentoo-5c182456307c63be9b383cfdd2b2b9979a20a91b.zip
xfce-extra/xfce4-clipman-plugin: Bump to 1.6.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfce4-clipman-plugin/Manifest1
-rw-r--r--xfce-extra/xfce4-clipman-plugin/xfce4-clipman-plugin-1.6.2.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-clipman-plugin/Manifest b/xfce-extra/xfce4-clipman-plugin/Manifest
index af1d33fb5cf4..f658655e3063 100644
--- a/xfce-extra/xfce4-clipman-plugin/Manifest
+++ b/xfce-extra/xfce4-clipman-plugin/Manifest
@@ -1 +1,2 @@
DIST xfce4-clipman-plugin-1.6.1.tar.bz2 471364 BLAKE2B cd037db1920aabde5f661401b9adbb81041e72688b431407c19865c10f3c61e41bbc034ff218461b108965b1d294ebd603be500dec7741687ddc0cdeeec69a6c SHA512 2a2aa5d7b5d841b11c6d54d4872fc8cbfb83981b2d4678075ff5aa2a4df9ea88de95b837bf3896d7ce5f434827ebb64238e68cca2e17a7104433ed5847d949dd
+DIST xfce4-clipman-plugin-1.6.2.tar.bz2 465656 BLAKE2B bde94cda7ec97d0af9f238bb3cffb69a7f469a03d27608681042ad701175a1900abed1d79bdc38d45afe5ed48da2054a837358bd150f5075bc194a9547bbf56f SHA512 4bd49b3b6311d232d422d92007638b05409bc0c90fdc20a394590000ac8c706c0502b99a3c89a0276ca1c0e2cfb0a151c78a0a8b18a16bbf65cc5778bcb51db2
diff --git a/xfce-extra/xfce4-clipman-plugin/xfce4-clipman-plugin-1.6.2.ebuild b/xfce-extra/xfce4-clipman-plugin/xfce4-clipman-plugin-1.6.2.ebuild
new file mode 100644
index 000000000000..98bbe22b672f
--- /dev/null
+++ b/xfce-extra/xfce4-clipman-plugin/xfce4-clipman-plugin-1.6.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit xdg-utils
+
+DESCRIPTION="A clipboard manager plug-in for the Xfce panel"
+HOMEPAGE="https://goodies.xfce.org/projects/panel-plugins/xfce4-clipman-plugin"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="qrcode"
+
+RDEPEND=">=dev-libs/glib-2.42:2=
+ >=x11-libs/gtk+-3.22.29:3=
+ x11-libs/libXtst:=
+ >=xfce-base/libxfce4ui-4.14:=
+ >=xfce-base/libxfce4util-4.14:=
+ >=xfce-base/xfce4-panel-4.14:=
+ >=xfce-base/xfconf-4.14:=
+ qrcode? ( >=media-gfx/qrencode-3.3.0:= )"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+ x11-base/xorg-proto"
+
+src_configure() {
+ local myconf=(
+ $(use_enable qrcode libqrencode)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}