summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-01 20:11:43 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-01 20:11:43 +0200
commit6970845df389e1468817c8c862fb35d4ea96272f (patch)
tree28405e702f54791fbfb03cd090fdf651808c7f50 /xfce-extra
parentdev-ml/opam-format: build with ocaml-4.12 (diff)
downloadgentoo-6970845df389e1468817c8c862fb35d4ea96272f.tar.gz
gentoo-6970845df389e1468817c8c862fb35d4ea96272f.tar.bz2
gentoo-6970845df389e1468817c8c862fb35d4ea96272f.zip
xfce-extra/xfce4-cpugraph-plugin: Bump to 1.2.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfce4-cpugraph-plugin/Manifest1
-rw-r--r--xfce-extra/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin-1.2.4.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-cpugraph-plugin/Manifest b/xfce-extra/xfce4-cpugraph-plugin/Manifest
index 2f7dc7430ffd..6cf2d486d6f2 100644
--- a/xfce-extra/xfce4-cpugraph-plugin/Manifest
+++ b/xfce-extra/xfce4-cpugraph-plugin/Manifest
@@ -1 +1,2 @@
DIST xfce4-cpugraph-plugin-1.2.3.tar.bz2 427880 BLAKE2B 1e2223eab1c8db275eb2aa43197c9aac8a79faee96778a5b684c0dc74e1b55046d0c1bbe3c00d316118be33ef3ee3777cafd258ef3919d36bbbb073e51fc9455 SHA512 79d7c5b328e778156c6a35b1f4947732f42aaffb23f05fdc5e1e7668d03149f1a72ca4bf9b835904a93db6b23660cb10118b4d046b1bd2dded38ef382719052e
+DIST xfce4-cpugraph-plugin-1.2.4.tar.bz2 445048 BLAKE2B 03c8c6f3aa0ffcfda930e79b851e6c6a425cab18986c7968fbdcecff3b251dc3134aab0c632d13439208445d0786e6e29a9835ccdff189bf82ae95b9b6576d6d SHA512 0a31b60d263f53db9e19165580c6f03a826e514f41b24555b007ae12b0d038d5f1447e637aa21e77cafe9970177dbeab373385e223f77768d46ede4f1adb0ad2
diff --git a/xfce-extra/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin-1.2.4.ebuild b/xfce-extra/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin-1.2.4.ebuild
new file mode 100644
index 000000000000..6e63cc625b45
--- /dev/null
+++ b/xfce-extra/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin-1.2.4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="A system load plug-in for the Xfce panel"
+HOMEPAGE="https://goodies.xfce.org/projects/panel-plugins/xfce4-cpugraph-plugin"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="BSD-2 GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND=">=x11-libs/gtk+-3.22:3
+ >=xfce-base/libxfce4ui-4.14:=
+ >=xfce-base/libxfce4util-4.14:=
+ >=xfce-base/xfce4-panel-4.14:="
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}