summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-10-09 21:19:04 +0200
committerMichał Górny <mgorny@gentoo.org>2021-10-09 21:31:27 +0200
commit810824a65a75aaa08fec2c723c92c7290ff8ed1a (patch)
tree8d4755fb0a68f2a9caa4a1df5296c5e7d25183c9 /xfce-extra
parentdev-python/beautifulsoup4: drop 4.9.3 (diff)
downloadgentoo-810824a65a75aaa08fec2c723c92c7290ff8ed1a.tar.gz
gentoo-810824a65a75aaa08fec2c723c92c7290ff8ed1a.tar.bz2
gentoo-810824a65a75aaa08fec2c723c92c7290ff8ed1a.zip
xfce-extra/xfce4-cpugraph-plugin: Bump to 1.2.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfce4-cpugraph-plugin/Manifest1
-rw-r--r--xfce-extra/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin-1.2.5.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-cpugraph-plugin/Manifest b/xfce-extra/xfce4-cpugraph-plugin/Manifest
index 6cf2d486d6f2..bbe1cca92180 100644
--- a/xfce-extra/xfce4-cpugraph-plugin/Manifest
+++ b/xfce-extra/xfce4-cpugraph-plugin/Manifest
@@ -1,2 +1,3 @@
DIST xfce4-cpugraph-plugin-1.2.3.tar.bz2 427880 BLAKE2B 1e2223eab1c8db275eb2aa43197c9aac8a79faee96778a5b684c0dc74e1b55046d0c1bbe3c00d316118be33ef3ee3777cafd258ef3919d36bbbb073e51fc9455 SHA512 79d7c5b328e778156c6a35b1f4947732f42aaffb23f05fdc5e1e7668d03149f1a72ca4bf9b835904a93db6b23660cb10118b4d046b1bd2dded38ef382719052e
DIST xfce4-cpugraph-plugin-1.2.4.tar.bz2 445048 BLAKE2B 03c8c6f3aa0ffcfda930e79b851e6c6a425cab18986c7968fbdcecff3b251dc3134aab0c632d13439208445d0786e6e29a9835ccdff189bf82ae95b9b6576d6d SHA512 0a31b60d263f53db9e19165580c6f03a826e514f41b24555b007ae12b0d038d5f1447e637aa21e77cafe9970177dbeab373385e223f77768d46ede4f1adb0ad2
+DIST xfce4-cpugraph-plugin-1.2.5.tar.bz2 455357 BLAKE2B 8408338e7bd858940b1c8b25d8c5f622e72bbbcd61a5b96d44a9c4a88438fac476d1911cbf65f42b8bca9c478e7703cbc2e6ce2668d1b5ef9cd4d68076df6113 SHA512 1a0b362afa2dcae30721dc468e31949e4edfe20f5e1063603111d0cd7fcbd3460f14d7ffd30ae1d687400661c37a51a9c1b2f7abedea6c9e9888e93fbbb56d4a
diff --git a/xfce-extra/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin-1.2.5.ebuild b/xfce-extra/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin-1.2.5.ebuild
new file mode 100644
index 000000000000..6e63cc625b45
--- /dev/null
+++ b/xfce-extra/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin-1.2.5.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="A system load plug-in for the Xfce panel"
+HOMEPAGE="https://goodies.xfce.org/projects/panel-plugins/xfce4-cpugraph-plugin"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="BSD-2 GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND=">=x11-libs/gtk+-3.22:3
+ >=xfce-base/libxfce4ui-4.14:=
+ >=xfce-base/libxfce4util-4.14:=
+ >=xfce-base/xfce4-panel-4.14:="
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}