summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-05-02 19:00:59 +0200
committerMichał Górny <mgorny@gentoo.org>2019-05-02 19:07:12 +0200
commit95c9cc3857b8c438df470d10304c9e6b48bb6eca (patch)
treebaf36aa3bf82e25fd0a5a705aba46c67a12f84c6 /xfce-extra
parentxfce-base/exo: Disable GTK+2 support in -r100 (diff)
downloadgentoo-95c9cc3857b8c438df470d10304c9e6b48bb6eca.tar.gz
gentoo-95c9cc3857b8c438df470d10304c9e6b48bb6eca.tar.bz2
gentoo-95c9cc3857b8c438df470d10304c9e6b48bb6eca.zip
xfce-extra/xfce4-places-plugin: Bump to 1.8.0 (GTK+3 port)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfce4-places-plugin/Manifest1
-rw-r--r--xfce-extra/xfce4-places-plugin/xfce4-places-plugin-1.8.0.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-places-plugin/Manifest b/xfce-extra/xfce4-places-plugin/Manifest
index a5c55a8b560a..63a77343553e 100644
--- a/xfce-extra/xfce4-places-plugin/Manifest
+++ b/xfce-extra/xfce4-places-plugin/Manifest
@@ -1 +1,2 @@
DIST xfce4-places-plugin-1.7.0.tar.bz2 371395 BLAKE2B fe18391e0cabe06d9d63dfc86a829e35461858b5915d7331053dfabbc9bb689bba0a3cc05b7d7f6dced6e19aa6e32308ba052cca9416bbfb2f050768d3e86f5e SHA512 ae324a29584d7dc6beb4840bec7e4c5802e94c25512f449ab959c588c91f4030d895fe185dad87ab9442611e9fe01f8ccec82e8cb5153cf192d1124156be6bd3
+DIST xfce4-places-plugin-1.8.0.tar.bz2 371134 BLAKE2B 5ef5cf79ce565a827520ed281a0be2533df643137d673f12d15393efb2a0ef5db1a18fff3c5e807cdb98d29a8ab4767469fa248cbca85c5a77d9a4e66aff6b59 SHA512 9db3b311881292a9cd380d505be8cd529b51ee92c25e0bbdcbc28dc099369cd7ea078e7c729856d9718967de8f8e2f08db045efb00a4be097d4ebf766da51263
diff --git a/xfce-extra/xfce4-places-plugin/xfce4-places-plugin-1.8.0.ebuild b/xfce-extra/xfce4-places-plugin/xfce4-places-plugin-1.8.0.ebuild
new file mode 100644
index 000000000000..1eaee9cc6808
--- /dev/null
+++ b/xfce-extra/xfce4-places-plugin/xfce4-places-plugin-1.8.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A panel plug-in to provide quick access to files, folders and removable media"
+HOMEPAGE="https://goodies.xfce.org/projects/panel-plugins/xfce4-places-plugin"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="libnotify"
+
+RDEPEND=">=dev-libs/glib-2.42:2
+ >=x11-libs/gtk+-3.22:3
+ x11-libs/libX11:=
+ >=xfce-base/exo-0.6:=
+ >=xfce-base/libxfce4ui-4.12:=
+ >=xfce-base/libxfce4util-4.12:=
+ >=xfce-base/xfce4-panel-4.12:=
+ >=xfce-base/xfconf-4.8:=
+ libnotify? ( >=x11-libs/libnotify-0.7:= )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_configure() {
+ local myconf=(
+ $(use_enable libnotify notifications)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}