summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-09-20 07:29:36 +0200
committerMichał Górny <mgorny@gentoo.org>2022-09-20 07:37:35 +0200
commitc9f1d7720569daa926be7569016aa58fe64fc412 (patch)
treeff73ce9a0421a17e7abc481bb5e2d82c50b76467 /xfce-extra
parentxfce-extra/xfce4-datetime-plugin: Bump to 0.8.2 (diff)
downloadgentoo-c9f1d7720569daa926be7569016aa58fe64fc412.tar.gz
gentoo-c9f1d7720569daa926be7569016aa58fe64fc412.tar.bz2
gentoo-c9f1d7720569daa926be7569016aa58fe64fc412.zip
xfce-extra/xfce4-places-plugin: Bump to 1.8.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfce4-places-plugin/Manifest1
-rw-r--r--xfce-extra/xfce4-places-plugin/xfce4-places-plugin-1.8.2.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-places-plugin/Manifest b/xfce-extra/xfce4-places-plugin/Manifest
index 480b7f3c106d..25ac35fe179a 100644
--- a/xfce-extra/xfce4-places-plugin/Manifest
+++ b/xfce-extra/xfce4-places-plugin/Manifest
@@ -1 +1,2 @@
DIST xfce4-places-plugin-1.8.1.tar.bz2 380906 BLAKE2B 3b5c82fe3fb9fbcc0b9aa79df62da06025f5dd154d4323787d52cbf659351dcc808a4c6e8d4148332eb31a8d292b51d58dba6c81fdf49443b94928a1e82f66f0 SHA512 c0db29050df6ff2862a6ebc6f89d92e39f0c0511f9e719a979b5132935655078a5f5418b8b87bee2fbccaa37f5489d503dc1ae329eb7fd88970dc55b31db3324
+DIST xfce4-places-plugin-1.8.2.tar.bz2 388168 BLAKE2B 4ffd6fddae71c40c82dd86427c742865a237d48650480db9b817e04f35d6b142896f51f63772f9ab3ca15f1fdccee492d442ee78a1033394154e561075ee66ac SHA512 ad298407183ea499bd4a7c923e80141886c7ca809f4af4184074a1c98e73c72fbf610e06bccdffe3c1bacce39d945dc094d0ea9a82ca67ff7f8b79c8d9c5c53d
diff --git a/xfce-extra/xfce4-places-plugin/xfce4-places-plugin-1.8.2.ebuild b/xfce-extra/xfce4-places-plugin/xfce4-places-plugin-1.8.2.ebuild
new file mode 100644
index 000000000000..6dbca3313e8d
--- /dev/null
+++ b/xfce-extra/xfce4-places-plugin/xfce4-places-plugin-1.8.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="A panel plug-in to provide quick access to files, folders and removable media"
+HOMEPAGE="
+ https://goodies.xfce.org/projects/panel-plugins/xfce4-places-plugin
+ https://gitlab.xfce.org/panel-plugins/xfce4-places-plugin/
+"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="libnotify"
+
+DEPEND="
+ >=dev-libs/glib-2.50:2
+ >=x11-libs/gtk+-3.22:3
+ x11-libs/libX11:=
+ >=xfce-base/exo-0.6:=
+ >=xfce-base/libxfce4ui-4.13:=
+ >=xfce-base/libxfce4util-4.12:=
+ >=xfce-base/xfce4-panel-4.12:=
+ >=xfce-base/xfconf-4.12:=
+ libnotify? ( >=x11-libs/libnotify-0.7:= )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local myconf=(
+ $(use_enable libnotify notifications)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}