summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-01 20:06:50 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-01 20:08:15 +0100
commitd2bcfaca94fd0abc787beac52d0af3ded5ec8223 (patch)
treeb08f4f2c06d656d5de741538fa1f5b4848cef23b /xfce-extra
parentpackage.mask: Remove leftover message (diff)
downloadgentoo-d2bcfaca94fd0abc787beac52d0af3ded5ec8223.tar.gz
gentoo-d2bcfaca94fd0abc787beac52d0af3ded5ec8223.tar.bz2
gentoo-d2bcfaca94fd0abc787beac52d0af3ded5ec8223.zip
xfce-extra/xfce4-clipman-plugin: Bump to 1.4.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfce4-clipman-plugin/Manifest1
-rw-r--r--xfce-extra/xfce4-clipman-plugin/xfce4-clipman-plugin-1.4.4.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-clipman-plugin/Manifest b/xfce-extra/xfce4-clipman-plugin/Manifest
index 0af910ec5267..69627ddf702f 100644
--- a/xfce-extra/xfce4-clipman-plugin/Manifest
+++ b/xfce-extra/xfce4-clipman-plugin/Manifest
@@ -1 +1,2 @@
DIST xfce4-clipman-plugin-1.4.3.tar.bz2 492784 BLAKE2B f52dc92976e0b826b7aab2b8a3b9e099bb31e3d670911608d7a39c9805b011bb4c77db1fb01379e3244682a4bcefba617e246cc9ade50ecd275ea554d928385f SHA512 28bc8e2be8dd3eac13a7988b68933ce84dd8cc756f0a19636cd5850d6e36714a73ad9650a28ebfc54d9ad3adb23c242abf89806124b4e00fe7d1701be1b52414
+DIST xfce4-clipman-plugin-1.4.4.tar.bz2 460114 BLAKE2B c3a6d8a9a3f36367bddf3803b86dc4bd5bf2dff94d675695caf95010c563b96b69ce4015d83568e9500f8f5d579f41ef8c5ce94804ecd58baa04f7cc9aa54f16 SHA512 4cb798faab4efdc7a5013cffd06ce527efbda4ba5b96063734d261a864f22075a2d6dd1f79a33c8bdfb39ceea8f89af3daac023aaed8a5a386c70604e8a77965
diff --git a/xfce-extra/xfce4-clipman-plugin/xfce4-clipman-plugin-1.4.4.ebuild b/xfce-extra/xfce4-clipman-plugin/xfce4-clipman-plugin-1.4.4.ebuild
new file mode 100644
index 000000000000..d763b3de7d1f
--- /dev/null
+++ b/xfce-extra/xfce4-clipman-plugin/xfce4-clipman-plugin-1.4.4.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2-utils
+
+DESCRIPTION="A clipboard manager plug-in for the Xfce panel"
+HOMEPAGE="https://goodies.xfce.org/projects/panel-plugins/xfce4-clipman-plugin"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="qrcode"
+
+RDEPEND=">=dev-libs/glib-2.32:2=
+ >=x11-libs/gtk+-3.14:3=
+ x11-libs/libXtst:=
+ >=xfce-base/libxfce4ui-4.12:=
+ >=xfce-base/libxfce4util-4.12:=
+ >=xfce-base/xfce4-panel-4.12:=
+ >=xfce-base/xfconf-4.10:=
+ qrcode? ( >=media-gfx/qrencode-3.3.0:= )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+ x11-base/xorg-proto"
+
+src_configure() {
+ local myconf=(
+ $(use_enable qrcode libqrencode)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}