summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJason Zaman <perfinion@gentoo.org>2015-09-14 12:15:55 +0800
committerJason Zaman <perfinion@gentoo.org>2015-09-14 12:16:27 +0800
commitdaa084258c5ae7fd1f78a42edbf103016a52127c (patch)
tree9bc6fbf860673068b55684a6883e6984e86183cc /xfce-extra
parentmedia-sound/quodlibet: Stable for PPC64 (bug #553622). (diff)
downloadgentoo-daa084258c5ae7fd1f78a42edbf103016a52127c.tar.gz
gentoo-daa084258c5ae7fd1f78a42edbf103016a52127c.tar.bz2
gentoo-daa084258c5ae7fd1f78a42edbf103016a52127c.zip
xfce-extra/xfswitch-plugin: Add in lxdm support
Gentoo-Bug: https://bugs.gentoo.org/526598 Package-Manager: portage-2.2.20.1
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfswitch-plugin/metadata.xml4
-rw-r--r--xfce-extra/xfswitch-plugin/xfswitch-plugin-0.0.1-r2.ebuild66
2 files changed, 69 insertions, 1 deletions
diff --git a/xfce-extra/xfswitch-plugin/metadata.xml b/xfce-extra/xfswitch-plugin/metadata.xml
index f6d547ab5488..bd3bfafbabf7 100644
--- a/xfce-extra/xfswitch-plugin/metadata.xml
+++ b/xfce-extra/xfswitch-plugin/metadata.xml
@@ -6,6 +6,8 @@
<name>XFCE Team</name>
</maintainer>
<use>
- <flag name='gdm'>Use gdmflexiserver from <pkg>gnome-base/gdm</pkg> instead of <pkg>x11-misc/lightdm</pkg></flag>
+ <flag name='gdm'>Compatibility with <pkg>gnome-base/gdm</pkg> only</flag>
+ <flag name='lightdm'>Compatibility with <pkg>x11-misc/lightdm</pkg> only</flag>
+ <flag name='lxdm'>Compatibility with <pkg>lxde-base/lxdm</pkg> only</flag>
</use>
</pkgmetadata>
diff --git a/xfce-extra/xfswitch-plugin/xfswitch-plugin-0.0.1-r2.ebuild b/xfce-extra/xfswitch-plugin/xfswitch-plugin-0.0.1-r2.ebuild
new file mode 100644
index 000000000000..74b05a48e29b
--- /dev/null
+++ b/xfce-extra/xfswitch-plugin/xfswitch-plugin-0.0.1-r2.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit multilib xfconf
+
+DESCRIPTION="A panel plug-in for user switching (using lightdm or gdm or ldm)"
+HOMEPAGE="http://goodies.xfce.org/projects/panel-plugins/xfswitch-plugin"
+SRC_URI="mirror://xfce/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+gdm lightdm lxdm"
+
+REQUIRED_USE="
+ gdm? (
+ !lightdm
+ !lxdm
+ )
+
+ lightdm? (
+ !gdm
+ !lxdm
+ )
+ lxdm? (
+ !gdm
+ !lightdm
+ )
+"
+
+COMMON_DEPEND=">=x11-libs/gtk+-2.12:2
+ >=xfce-base/libxfce4util-4.8
+ >=xfce-base/libxfcegui4-4.8
+ >=xfce-base/xfce4-panel-4.8"
+RDEPEND="${COMMON_DEPEND}
+ gdm? ( gnome-base/gdm )
+ lightdm? ( x11-misc/lightdm )
+ lxdm? ( lxde-base/lxdm )"
+DEPEND="${COMMON_DEPEND}
+ dev-util/intltool
+ virtual/pkgconfig
+ sys-devel/gettext"
+
+pkg_setup() {
+ XFCONF=(
+ --libexecdir="${EPREFIX}"/usr/$(get_libdir)
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS README )
+}
+
+src_prepare() {
+ if use lightdm; then #411921, 526598
+ sed -i \
+ -e '/command/s:gdmflexiserver --new:/usr/bin/dm-tool switch-to-greeter:' \
+ panel-plugin/main.c || die
+ elif use lxdm; then
+ sed -i \
+ -e '/command/s:gdmflexiserver --new:/usr/sbin/lxdm -c USER_SWITCH:' \
+ panel-plugin/main.c || die
+ fi
+
+ xfconf_src_prepare
+}