summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnome-base/dconf-editor/Manifest1
-rw-r--r--gnome-base/dconf-editor/dconf-editor-3.30.2.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/gnome-base/dconf-editor/Manifest b/gnome-base/dconf-editor/Manifest
index 2b9433e58ef0..fe6beead9d1f 100644
--- a/gnome-base/dconf-editor/Manifest
+++ b/gnome-base/dconf-editor/Manifest
@@ -1,2 +1,3 @@
DIST dconf-editor-3.26.2.tar.xz 542828 BLAKE2B e7bd35b39d7b0124105513d44f3a24d005f1c6daf2dccb1d3eeb324b65038adfc11e5ee83078058489b1e918222538a97621c74fb0a0ceb20e1a708ccf5a82bd SHA512 25a6536c97b4f6fc26890915e2d0ed3ff1d2247175fd25a7d86e44f33da8667064415b22890c799d3586cd0f08becc90414f02bf3d988aa1d02eee90d7e45ba5
DIST dconf-editor-3.28.0.tar.xz 417244 BLAKE2B 1237b199b7b991055fe30829dff0554be7e3122001c9c1a3bd1b17dc1aeeb0a4df6536560b072559c96d4da0b26bdf234479cb9c38ae979d08c220348df48649 SHA512 435c159fd3356c19e459ed9441671b508c5ba1b2d9f491d304280ef66b980779fda5769bb2e1e85a294ceebe9e729e4899ac0ab750f86e5ccdbdc455cf1ffc44
+DIST dconf-editor-3.30.2.tar.xz 447060 BLAKE2B 4cd8ab7200afaa402d6915a94be12b32a58fdf11ed77d4b833e3734b94de99bf7182d3564d1e0b42935d4364b2c973c296d773de402942af8e66f4ccbe6026be SHA512 c9fe4393e9c75ad19c56670a50199493a32ed55f3135ada599aef5efb4582320a23648da1906ce1a1b64918987fd3684f00bfc749a21a6fd2806066d760418c8
diff --git a/gnome-base/dconf-editor/dconf-editor-3.30.2.ebuild b/gnome-base/dconf-editor/dconf-editor-3.30.2.ebuild
new file mode 100644
index 000000000000..a8ec49357250
--- /dev/null
+++ b/gnome-base/dconf-editor/dconf-editor-3.30.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+VALA_MIN_API_VERSION="0.40"
+
+inherit gnome.org gnome2-utils meson vala xdg
+
+DESCRIPTION="Graphical tool for editing the dconf configuration database"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/dconf-editor"
+
+LICENSE="GPL-3+"
+SLOT="0"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-linux"
+
+RDEPEND="
+ >=gnome-base/dconf-0.26.1
+ >=dev-libs/glib-2.55.1:2
+ >=x11-libs/gtk+-3.22.27:3
+"
+DEPEND="${RDEPEND}
+ $(vala_depend)
+ dev-libs/libxml2:2
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ vala_src_prepare
+ xdg_src_prepare
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_icon_cache_update
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_icon_cache_update
+ gnome2_schemas_update
+}