summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-analyzer/python-gvm/Manifest1
-rw-r--r--net-analyzer/python-gvm/python-gvm-1.5.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/net-analyzer/python-gvm/Manifest b/net-analyzer/python-gvm/Manifest
index 3dfcb652f5f4..628af619e9a0 100644
--- a/net-analyzer/python-gvm/Manifest
+++ b/net-analyzer/python-gvm/Manifest
@@ -1,2 +1,3 @@
DIST python-gvm-1.1.0.tar.gz 160289 BLAKE2B 64dbf79f6749c50cddc2b908c45c6aea6c3793f0ddb10a98a96870636ee351f1a2e66227fbcc1383c63e0e015b4c05bf4c116ac80ef35f73f7e9057f9c8dd9b5 SHA512 dae04d42a14adde274c2148f7bd4b47b0ea02d6e249d6c23dfeb15f217f04ad9ff722f2e98d13e1a7add7b61d9dabfec623ab5b45087aaf5f480447fd31a8071
DIST python-gvm-1.2.0.tar.gz 160700 BLAKE2B 40ef2d6e01dee7a93796c5d2f29db06e2a533860f7c612000ad5250d9b291ce90164e3a7c65c77f7131fc12c4622094b22da4eeb989293ad1b33e2754063ec76 SHA512 3eacec521bbd4cbfaec08d1ccabfe1c97898288b8b56779f9e3ceb734f52d78b93faf92674c1eefc555501e0bfdb16ed26316e87c697bbdc5a673d1be2170c00
+DIST python-gvm-1.5.0.tar.gz 171471 BLAKE2B 57fa3cc8dfa74a16c56fb4fee0f2c47ede441892a19865271e8c034cb853751f38b3f90cbca6d538d8e59866cd45d0fd8e783a62719c523c6fc9723f4c183a79 SHA512 7c1717dd8f724566232cca50997494012d0364975151afcca8aa483f9fd85d47343f1a2af0124cb762e16d42a057b06d8f8a5e637280e14541a270b14be188e1
diff --git a/net-analyzer/python-gvm/python-gvm-1.5.0.ebuild b/net-analyzer/python-gvm/python-gvm-1.5.0.ebuild
new file mode 100644
index 000000000000..8f7d966921fb
--- /dev/null
+++ b/net-analyzer/python-gvm/python-gvm-1.5.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+
+inherit distutils-r1
+
+DESCRIPTION="Greenbone Vulnerability Management Python Library"
+HOMEPAGE="https://www.greenbone.net/en/"
+SRC_URI="https://github.com/greenbone/python-gvm/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/paramiko[${PYTHON_USEDEP}]"
+
+DEPEND="
+ ${RDEPEND}"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ distutils-r1_python_prepare_all
+ # Exlude tests & docs to fix build issue
+ sed \
+ -e "s/packages=find_packages(exclude=.*/packages=find_packages(exclude=['tests*', 'docs']),/g" \
+ -i "$S"/setup.py || die
+}