summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www-servers/tornado/tornado-6.1.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/www-servers/tornado/tornado-6.1.ebuild b/www-servers/tornado/tornado-6.1.ebuild
index aad1b1cbc58d..a956fc321b85 100644
--- a/www-servers/tornado/tornado-6.1.ebuild
+++ b/www-servers/tornado/tornado-6.1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{7..10} )
PYTHON_REQ_USE="threads(+)"
inherit distutils-r1
@@ -32,6 +32,14 @@ distutils_enable_sphinx docs \
dev-python/sphinx_rtd_theme \
dev-python/sphinxcontrib-asyncio
+python_prepare_all() {
+ # Disable deprecation-warnings-as-errors because tornado has a lot of stuff deprecated in 3.10
+ sed 's/warnings.filterwarnings("error", category=DeprecationWarning, module=r"tornado\\..*")//' \
+ -i tornado/test/runtests.py || die
+
+ distutils-r1_python_prepare_all
+}
+
python_test() {
local -x ASYNC_TEST_TIMEOUT=60
cd "${BUILD_DIR}/lib" || die