summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ml/uunf/Manifest1
-rw-r--r--dev-ml/uunf/uunf-14.0.0.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-ml/uunf/Manifest b/dev-ml/uunf/Manifest
index 7f4a79e2e136..fe5af61d2cd6 100644
--- a/dev-ml/uunf/Manifest
+++ b/dev-ml/uunf/Manifest
@@ -1 +1,2 @@
DIST uunf-13.0.0.tbz 39387 BLAKE2B fa8c46f63e2f8cf44cffe0db8c0aea73a0ffb6449f4a3c7c59baf4750db8e2364686276e6e5f284b2a528a45f02400274669c4e081533fbb25cdd36c6eb8fcb0 SHA512 ade9815b1d620a055a63dd0f8c5d5c54544eacfdcf0c6059cd20f1004a1319287f71021018fbc7e652bde738a97fae7e9d0963d5b192a4b0bb6e5b95456012a8
+DIST uunf-14.0.0.tbz 41632 BLAKE2B f2c6523f773b77905092f14934ff40a1deaf76c3f769df6d00f5c743ac9d240a78838142016b7b0eb9d2c9a132c3c2df67e31bf433ec9888e9cc2b831cf45d67 SHA512 9aac01483abb8a8a5d68832d7f7692909d61559f2c9b0284c1da293f8115d1100df26e9e4cf7280bda6499ba866f5da2c72c4c21ca99a1d594b29d000e9bb051
diff --git a/dev-ml/uunf/uunf-14.0.0.ebuild b/dev-ml/uunf/uunf-14.0.0.ebuild
new file mode 100644
index 000000000000..8d806d41586d
--- /dev/null
+++ b/dev-ml/uunf/uunf-14.0.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit opam
+
+DESCRIPTION="Unicode text normalization"
+HOMEPAGE="https://erratique.ch/software/uunf https://github.com/dbuenzli/uunf"
+SRC_URI="https://erratique.ch/software/uunf/releases/${P}.tbz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-ml/topkg:=
+ dev-ml/uutf:=
+ dev-ml/cmdliner:="
+RDEPEND="${DEPEND}"
+BDEPEND="dev-ml/findlib"
+OPAM_FILE=opam
+
+src_compile() {
+ # Increase stack limit to 11GiB to avoid stack overflow error.
+ # bug #798270
+ ulimit -s 11530000
+
+ ocaml pkg/pkg.ml build \
+ || die
+}