summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-fs/ext3grep/ext3grep-0.10.2.ebuild30
-rw-r--r--sys-fs/ext3grep/files/ext3grep-0.10.2-include-unistd_h-for-sysconf.patch4
-rw-r--r--sys-fs/ext3grep/files/ext3grep-0.10.2-new-e2fsprogs.patch (renamed from sys-fs/ext3grep/files/ext3grep-0.10.2-new-e2fsprogs.diff)0
-rw-r--r--sys-fs/ext3grep/files/ext3grep-0.10.2-newer-e2fsprogs.patch22
4 files changed, 38 insertions, 18 deletions
diff --git a/sys-fs/ext3grep/ext3grep-0.10.2.ebuild b/sys-fs/ext3grep/ext3grep-0.10.2.ebuild
index 88c27978d04d..1c8c5533ad98 100644
--- a/sys-fs/ext3grep/ext3grep-0.10.2.ebuild
+++ b/sys-fs/ext3grep/ext3grep-0.10.2.ebuild
@@ -1,8 +1,7 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
-inherit eutils
+EAPI=6
DESCRIPTION="Recover deleted files on an ext3 file system"
HOMEPAGE="https://code.google.com/p/ext3grep/"
@@ -13,25 +12,24 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="debug pch"
-DOCS="NEWS README"
-
-RDEPEND=""
DEPEND="sys-fs/e2fsprogs
virtual/os-headers
virtual/pkgconfig"
-src_prepare() {
- epatch \
- "${FILESDIR}"/${PN}-0.10.1-gcc44.patch \
- "${FILESDIR}"/${P}-include-unistd_h-for-sysconf.patch
+DOCS="NEWS README"
- # Fix build against latest e2fsprogs, taken from
- # https://code.google.com/p/ext3grep/issues/detail?id=34
- epatch "${FILESDIR}"/${P}-new-e2fsprogs.diff
-}
+PATCHES=(
+ "${FILESDIR}/${PN}-0.10.1-gcc44.patch"
+ "${FILESDIR}/${P}-include-unistd_h-for-sysconf.patch"
+ "${FILESDIR}/${P}-new-e2fsprogs.patch"
+ "${FILESDIR}/${P}-newer-e2fsprogs.patch"
+)
src_configure() {
- econf \
- $(use_enable debug) \
+ myeconfargs=(
+ $(use_enable debug)
$(use_enable pch)
+ )
+
+ econf "${myeconfargs[@]}"
}
diff --git a/sys-fs/ext3grep/files/ext3grep-0.10.2-include-unistd_h-for-sysconf.patch b/sys-fs/ext3grep/files/ext3grep-0.10.2-include-unistd_h-for-sysconf.patch
index bf38c27e7095..42588f71d6e5 100644
--- a/sys-fs/ext3grep/files/ext3grep-0.10.2-include-unistd_h-for-sysconf.patch
+++ b/sys-fs/ext3grep/files/ext3grep-0.10.2-include-unistd_h-for-sysconf.patch
@@ -1,7 +1,7 @@
http://bugs.gentoo.org/422789
---- src/init_consts.cc
-+++ src/init_consts.cc
+--- a/src/init_consts.cc
++++ b/src/init_consts.cc
@@ -27,6 +27,10 @@
#include "debug.h"
#endif
diff --git a/sys-fs/ext3grep/files/ext3grep-0.10.2-new-e2fsprogs.diff b/sys-fs/ext3grep/files/ext3grep-0.10.2-new-e2fsprogs.patch
index 45b54b807bd7..45b54b807bd7 100644
--- a/sys-fs/ext3grep/files/ext3grep-0.10.2-new-e2fsprogs.diff
+++ b/sys-fs/ext3grep/files/ext3grep-0.10.2-new-e2fsprogs.patch
diff --git a/sys-fs/ext3grep/files/ext3grep-0.10.2-newer-e2fsprogs.patch b/sys-fs/ext3grep/files/ext3grep-0.10.2-newer-e2fsprogs.patch
new file mode 100644
index 000000000000..8a029f9916b6
--- /dev/null
+++ b/sys-fs/ext3grep/files/ext3grep-0.10.2-newer-e2fsprogs.patch
@@ -0,0 +1,22 @@
+--- a/src/ext3.h 2008-04-09 13:20:31.000000000 +0200
++++ b/src/ext3.h 2018-05-07 23:16:35.413754674 +0200
+@@ -106,7 +106,7 @@
+ __u32 const* block(void) const { return i_block; }
+ __u32 generation(void) const { return i_generation; }
+ __u32 file_acl(void) const { return i_file_acl; }
+- __u32 dir_acl(void) const { return i_dir_acl; }
++ __u32 size_high(void) const { return i_size_high; }
+ __u32 faddr(void) const { return i_faddr; }
+ __u16 uid_high(void) const { return i_uid_high; }
+ __u16 gid_high(void) const { return i_gid_high; }
+--- a/src/print_inode_to.cc 2008-10-17 03:27:15.000000000 +0200
++++ b/src/print_inode_to.cc 2018-05-07 23:16:54.379754601 +0200
+@@ -118,7 +118,7 @@
+ os << '\n';
+ }
+ //os << "File ACL: " << inode.file_acl() << '\n';
+- //os << "Directory ACL: " << inode.dir_acl() << '\n';
++ //os << "Directory ACL: " << inode.size_high() << '\n';
+ //os << "Fragment address: " << inode.faddr() << '\n';
+ //os << "Fragment number: " << (int)inode.osd2.linux2.l_i_frag << '\n';
+ //os << "Fragment size: " << (int)inode.osd2.linux2.l_i_fsize << '\n';